cerhu > linux.debian.user.french

Guillaume Membré (31/12/2006, 17h10)
Bonjour,

j'ai un soucis avec dpkg et je ne trouve pas de solution.
Je suis en debian sid.
voici mon source.list :
deb [..] stable main non-free contrib
deb [..] testing/updates main contrib non-free
deb [..] sid main
deb [..] testing main non-free contrib

Je possede une carte d'enregistrement video PVR 350 qui necessite
absolument un server Xorg 6.8.2 (le driver disponible a été compilé
uniquement pour cette version de Xorg) Cette tres vieille version de
X, qui marche tres bien soit dit en passant, me pose de nombreux lors
de mes updates : apt-get veut me le desinstaller a profit du nouveau
Xorg 7.
Je ne veux en aucun cas effectuer cette mise a jour sinon ma carte ne
marchera plus.

voici ce qui se passe :
> apt-get install gedit

Reading package lists... Done
Building dependency tree... Done
The following extra packages will be installed:
libdrm2 libgtksourceview-common libgtksourceview1.0-0 libxau-dev
libxau6 libxfixes-dev libxfixes3 libxklavier10 msttcorefonts
python-gnome2-desktop x-dev x11-common x11proto-core-dev
x11proto-fixes-dev x11proto-input-dev x11proto-xext-dev xbase-clients
xfonts-100dpi xfonts-75dpi xfonts-75dpi-transcoded xfonts-base
xfonts-encodings xfonts-utils xserver-xorg xserver-xorg-core
xserver-xorg-input-all xserver-xorg-input-evdev
xserver-xorg-input-kbd xserver-xorg-input-mouse
xserver-xorg-input-synaptics
xserver-xorg-input-wacom xserver-xorg-video-all
xserver-xorg-video-apm xserver-xorg-video-ark xserver-xorg-video-ati
xserver-xorg-video-chips xserver-xorg-video-cirrus
xserver-xorg-video-cyrix xserver-xorg-video-dummy
xserver-xorg-video-fbdev
xserver-xorg-video-glint xserver-xorg-video-i128
xserver-xorg-video-i740 xserver-xorg-video-i810
xserver-xorg-video-imstt
xserver-xorg-video-mga xserver-xorg-video-neomagic
xserver-xorg-video-newport xserver-xorg-video-nsc
xserver-xorg-video-nv
xserver-xorg-video-rendition xserver-xorg-video-s3
xserver-xorg-video-s3virge xserver-xorg-video-savage
xserver-xorg-video-siliconmotion
xserver-xorg-video-sis xserver-xorg-video-sisusb
xserver-xorg-video-tdfx xserver-xorg-video-tga
xserver-xorg-video-trident
xserver-xorg-video-tseng xserver-xorg-video-v4l
xserver-xorg-video-vesa xserver-xorg-video-vga xserver-xorg-video-via
xserver-xorg-video-vmware xserver-xorg-video-voodoo
Suggested packages:
python-gnome2-desktop-doc x-window-system-core x-window-system
mesa-utils xfs xserver libglide2 gsynaptics ksynaptics qsynaptics
Recommended packages:
x-ttcidfont-conf xresprobe mdetect discover1 discover
The following packages will be REMOVED:
artwiz-cursor lbxproxy proxymngr twm xfonts-base-transcoded
xserver-common xterm xutils xvfb
The following NEW packages will be installed:
gedit libdrm2 libxau-dev python-gnome2-desktop x11proto-core-dev
x11proto-fixes-dev x11proto-input-dev x11proto-xext-dev
xfonts-encodings
xfonts-utils xserver-xorg-core xserver-xorg-input-all
xserver-xorg-input-evdev xserver-xorg-input-kbd
xserver-xorg-input-mouse
xserver-xorg-input-synaptics xserver-xorg-input-wacom
xserver-xorg-video-all xserver-xorg-video-apm xserver-xorg-video-ark
xserver-xorg-video-ati xserver-xorg-video-chips
xserver-xorg-video-cirrus xserver-xorg-video-cyrix
xserver-xorg-video-dummy
xserver-xorg-video-fbdev xserver-xorg-video-glint
xserver-xorg-video-i128 xserver-xorg-video-i740
xserver-xorg-video-i810
xserver-xorg-video-imstt xserver-xorg-video-mga
xserver-xorg-video-neomagic xserver-xorg-video-newport
xserver-xorg-video-nsc
xserver-xorg-video-nv xserver-xorg-video-rendition
xserver-xorg-video-s3 xserver-xorg-video-s3virge
xserver-xorg-video-savage
xserver-xorg-video-siliconmotion xserver-xorg-video-sis
xserver-xorg-video-sisusb xserver-xorg-video-tdfx
xserver-xorg-video-tga
xserver-xorg-video-trident xserver-xorg-video-tseng
xserver-xorg-video-v4l xserver-xorg-video-vesa xserver-xorg-video-vga
xserver-xorg-video-via xserver-xorg-video-vmware xserver-xorg-video-voodoo
The following held packages will be changed:
xserver-xorg
The following packages will be upgraded:
libgtksourceview-common libgtksourceview1.0-0 libxau6 libxfixes-dev
libxfixes3 libxklavier10 msttcorefonts x-dev x11-common xbase-clients
xfonts-100dpi xfonts-75dpi xfonts-75dpi-transcoded xfonts-base xserver-xorg
15 upgraded, 53 newly installed, 9 to remove and 732 not upgraded.
Need to get 30.2MB of archives.
After unpacking 9556kB disk space will be freed.
Do you want to continue [Y/n]?

Comment est ce que je peux verrouiller la mise a jour de certains paquets svp ?

Merci d'avance
Cordialement
Guillaume
Jean-Michel OLTRA (01/01/2007, 00h30)
Bonjour,

Le dimanche 31 décembre 2006, Guillaume Membré a écrit...

> Comment est ce que je peux verrouiller la mise a jour de certains paquets
> svp ?


Tu peux utiliser dpkg :

dpkg --get-selections > fichier
Tu édites fichier, et tu mets les paquets désirés en 'hold', au lieu de
'install'.
Puis tu renseignes dpkg par un :
dpkg --set-selections < fichier

Sinon, il vaut mieux utiliser aptitude, et il y a une option de menu
pour ce faire.
Guillaume Membré (02/01/2007, 00h40)
Bonjour,

merci pour votre aide.

j'ai essayé avec dpkg et le resultat est toujours le meme.
Voici les packages que j'ai mis en hold :
> dpkg --get-selections| grep hold

artwiz-cursor hold
lbxproxy hold
proxymngr hold
twm hold
x-dev hold
x11-common hold
xbase-clients hold
xfonts-100dpi hold
xfonts-75dpi hold
xfonts-75dpi-transcoded hold
xfonts-base hold
xfonts-base-transcoded hold
xlibmesa-dri hold
xlibmesa-gl hold
xlibmesa-gl-dev hold
xlibs hold
xlibs-data hold
xlibs-static-dev hold
xlibs-static-pic hold
xserver-common hold
xserver-xorg hold
xterm hold
xutils hold
xvfb hold

> apt-get install gedit

Reading package lists... Done
Building dependency tree... Done
The following extra packages will be installed:
libdrm2 libgtksourceview-common libgtksourceview1.0-0 libxau-dev
libxau6 libxfixes-dev libxfixes3
libxklavier10 msttcorefonts python-gnome2-desktop x-dev x11-common
x11proto-core-dev x11proto-fixes-dev
x11proto-input-dev x11proto-xext-dev xbase-clients xfonts-100dpi
xfonts-75dpi xfonts-75dpi-transcoded
xfonts-base xfonts-encodings xfonts-utils xserver-xorg
xserver-xorg-core xserver-xorg-input-all
xserver-xorg-input-evdev xserver-xorg-input-kbd
xserver-xorg-input-mouse xserver-xorg-input-synaptics
xserver-xorg-input-wacom xserver-xorg-video-all
xserver-xorg-video-apm xserver-xorg-video-ark
xserver-xorg-video-ati xserver-xorg-video-chips
xserver-xorg-video-cirrus xserver-xorg-video-cyrix
xserver-xorg-video-dummy xserver-xorg-video-fbdev
xserver-xorg-video-glint xserver-xorg-video-i128
xserver-xorg-video-i740 xserver-xorg-video-i810
xserver-xorg-video-imstt xserver-xorg-video-mga
xserver-xorg-video-neomagic xserver-xorg-video-newport
xserver-xorg-video-nsc xserver-xorg-video-nv
xserver-xorg-video-rendition xserver-xorg-video-s3
xserver-xorg-video-s3virge xserver-xorg-video-savage
xserver-xorg-video-siliconmotion xserver-xorg-video-sis
xserver-xorg-video-sisusb
xserver-xorg-video-tdfx xserver-xorg-video-tga
xserver-xorg-video-trident xserver-xorg-video-tseng
xserver-xorg-video-v4l xserver-xorg-video-vesa
xserver-xorg-video-vga xserver-xorg-video-via
xserver-xorg-video-vmware xserver-xorg-video-voodoo
Suggested packages:
python-gnome2-desktop-doc x-window-system-core x-window-system
mesa-utils xfs xserver libglide2
gsynaptics ksynaptics qsynaptics
Recommended packages:
x-ttcidfont-conf xresprobe mdetect discover1 discover xlibs
The following packages will be REMOVED:
artwiz-cursor lbxproxy proxymngr twm xfonts-base-transcoded
xserver-common xterm xutils xvfb
The following NEW packages will be installed:
gedit libdrm2 libxau-dev python-gnome2-desktop x11proto-core-dev
x11proto-fixes-dev x11proto-input-dev
x11proto-xext-dev xfonts-encodings xfonts-utils xserver-xorg-core
xserver-xorg-input-all
xserver-xorg-input-evdev xserver-xorg-input-kbd
xserver-xorg-input-mouse xserver-xorg-input-synaptics
xserver-xorg-input-wacom xserver-xorg-video-all
xserver-xorg-video-apm xserver-xorg-video-ark
xserver-xorg-video-ati xserver-xorg-video-chips
xserver-xorg-video-cirrus xserver-xorg-video-cyrix
xserver-xorg-video-dummy xserver-xorg-video-fbdev
xserver-xorg-video-glint xserver-xorg-video-i128
xserver-xorg-video-i740 xserver-xorg-video-i810
xserver-xorg-video-imstt xserver-xorg-video-mga
xserver-xorg-video-neomagic xserver-xorg-video-newport
xserver-xorg-video-nsc xserver-xorg-video-nv
xserver-xorg-video-rendition xserver-xorg-video-s3
xserver-xorg-video-s3virge xserver-xorg-video-savage
xserver-xorg-video-siliconmotion xserver-xorg-video-sis
xserver-xorg-video-sisusb
xserver-xorg-video-tdfx xserver-xorg-video-tga
xserver-xorg-video-trident xserver-xorg-video-tseng
xserver-xorg-video-v4l xserver-xorg-video-vesa
xserver-xorg-video-vga xserver-xorg-video-via
xserver-xorg-video-vmware xserver-xorg-video-voodoo
The following held packages will be changed:
artwiz-cursor lbxproxy proxymngr twm x-dev x11-common xbase-clients
xfonts-100dpi xfonts-75dpi
xfonts-75dpi-transcoded xfonts-base xfonts-base-transcoded
xserver-common xserver-xorg xterm xutils
xvfb
The following packages will be upgraded:
libgtksourceview-common libgtksourceview1.0-0 libxau6 libxfixes-dev
libxfixes3 libxklavier10
msttcorefonts x-dev x11-common xbase-clients xfonts-100dpi
xfonts-75dpi xfonts-75dpi-transcoded
xfonts-base xserver-xorg
15 upgraded, 53 newly installed, 9 to remove and 733 not upgraded.
Need to get 30.2MB of archives.
After unpacking 9556kB disk space will be freed.

Qu'est ce que j'ai loupé ?

merci encore
Guillaume

On 12/31/06, Jean-Michel OLTRA <jm.oltra.antispam> wrote:
[..]
Jean-Michel OLTRA (02/01/2007, 14h00)
Bonjour,

Le lundi 01 janvier 2007, Guillaume Membré a écrit...

> j'ai essayé avec dpkg et le resultat est toujours le meme.
> Voici les packages que j'ai mis en hold :


> >apt-get install gedit

> The following NEW packages will be installed:
> gedit libdrm2 libxau-dev python-gnome2-desktop x11proto-core-dev


> Qu'est ce que j'ai loupé ?


Je ne suis pas un spécialiste du paquet, mais peut-être que ce que tu
demandes n'est pas possible : par exemple (au hasard) il te faut
python-gnome2-desktop pour gedit. Mais si ce dernier dépend d'autres
paquets avec des versions bien précises, alors il va falloir qu'ils
soient installés...et ainsi de suite en cascade (et avec Gnome, on ne
sait jamais où s'arrête la cascade...).

Peut-être qu'il te faudrait essayer d'installer gedit avec une version
précise, qui ne serait pas la dernière en date.
Guillaume Membré (02/01/2007, 15h10)
Bonjour,

On 1/2/07, Jean-Michel OLTRA <jm.oltra.antispam> wrote:
[..]
> Je ne suis pas un spécialiste du paquet, mais peut-être que ce que tu
> demandes n'est pas possible : par exemple (au hasard) il te faut
> python-gnome2-desktop pour gedit. Mais si ce dernier dépend d'autres
> paquets avec des versions bien précises, alors il va falloir qu'ils
> soient installés...et ainsi de suite en cascade (et avec Gnome, on ne
> sait jamais où s'arrête la cascade...).
> Peut-être qu'il te faudrait essayer d'installer gedit avec une version
> précise, qui ne serait pas la dernière en date.


je pense que c'est ce qu'il se passe mais j'aurais esperer que le
systeme de package me reponde alors : le package libxau-dev est
verrouillé, l'installation de gedit n'est pas possible et qu'il
s'arrete au lieu de me proposer tout de meme l'installation.
Si je fais un dist-upgrade, je suis alors sur de casser mon serveur X :(

Guillaume
[..]
Jean-Michel OLTRA (03/01/2007, 03h00)
Bonjour,

Le mardi 02 janvier 2007, Guillaume Membré a écrit...

> je pense que c'est ce qu'il se passe mais j'aurais esperer que le
> systeme de package me reponde alors : le package libxau-dev est
> verrouillé, l'installation de gedit n'est pas possible et qu'il
> s'arrete au lieu de me proposer tout de meme l'installation.
> Si je fais un dist-upgrade, je suis alors sur de casser mon serveur X :(


aptitude est censé gérer les dépendances plus finement. Il aurait
peut-être un autre comportement au visuel (mais le résultat serait le
même).
Discussions similaires
dpkg: error: failed to write status database record about 'libclutter-1.0-0:i386' to 'var/lib/dpkg/status': No space left on device

installations avec apt-get des dépendances d'un paq uet local installé avec dpkg

upgrade woody vers sarge (dpkg: parse error, in file `/var/lib/dpkg/available)

[newbie][dpkg][sarge] Problemes de sortie en erreur...


Fuseau horaire GMT +2. Il est actuellement 05h33. | Privacy Policy