cerhu > comp.divers.* > comp.applications.x11

Jogo (24/01/2009, 12h17)
Bonjour,

J'ai essayé de compiler Xorg à la main. Tout marche maintenant
correctement sauf le driver nv. Il me jette avec :

--- Xorg.2.log ---
(II) Primary Device is: ISA
(EE) No devices detected.

Fatal server error:
no screens found
--- Xorg.2.log ---

J'ai essayé la version 2.1.12 de nv avec les serveur 1.5.1, 1.5.3 et
1.4.2, et nv 2.1.3 avec server 1.4.2, c'est toujours la même erreur.

lspci donne :
01:00.0 VGA compatible controller: nVidia Corporation NV18
[GeForce4 MX440 AGP 8x] (rev a2)

Voilà, du coup j'utilise vesa, mais c'est lent et j'ai pas de Xv. Que
me conseillez-vous pour que ça marche enfin ?
Nicolas George (24/01/2009, 13h16)
Jogo wrote in message <20090124111747.bed7b1bd.jogo>:
> J'ai essayé de compiler Xorg à la main. Tout marche maintenant
> correctement sauf le driver nv. Il me jette avec :
> --- Xorg.2.log ---
> (II) Primary Device is: ISA
> (EE) No devices detected.
> Fatal server error:
> no screens found
> --- Xorg.2.log ---


Il y a probablement des indications plus détaillées plus haut. Et montrer
ton xorg.conf pourrait aider.
Jogo (24/01/2009, 13h47)
Sur fr.comp.applications.x11, Nicolas George disait :

> Il y a probablement des indications plus détaillées plus haut.


Non, vraiment. Il me dit qu'il ne peut pas charger glx et qu'il ne
peut pas ouvrir ACPI. J'ai déjà essayer de le rendre le plus verbeux
possible, mais ça ne change rien. Si tu veux je te ai mis le log là :
[..]

> Et montrer ton xorg.conf pourrait aider.


Vraiment rien de particulier là non plus. En voici quelques extraits :

Section "Module"
Load "dbe" # Double buffer extension
SubSection "extmod"
Option "omit xfree86-dga" # don't initialise the DGA
extension EndSubSection
Load "freetype"
EndSection

Section "Monitor"
Identifier "iiyama"
HorizSync 30-96
VertRefresh 50-160
EndSection

Section "Device"
Identifier "nv"
Driver "nv"
EndSection

Section "Screen"
Identifier "Screen 1"
Device "nv"
Monitor "iiyama"
DefaultDepth 24

Subsection "Display"
Depth 8
Modes "1280x1024" "1024x768" "800x600" "640x480"
ViewPort 0 0
EndSubsection
Subsection "Display"
Depth 16
Modes "1280x960" "1280x1024" "1024x768" "800x600"
"640x480" ViewPort 0 0
EndSubsection
Subsection "Display"
Depth 24
Modes "1280x960" "1280x1024" "1024x768" "800x600"
"640x480" ViewPort 0 0
EndSubsection
EndSection

Section "ServerLayout"
Identifier "Simple Layout"
Screen "Screen 1"
InputDevice "Mouse1" "CorePointer"
InputDevice "Keyboard1" "CoreKeyboard"
EndSection

Et j'ai exactement le même log si j'ajoute «BusID "PCI:1:0:0"» à
la section Device.
Nicolas George (24/01/2009, 15h37)
Jogo wrote in message <20090124111747.bed7b1bd.jogo>:
> (II) Primary Device is: ISA


C'est bizarre, d'après <URL:
[..]
Jogo (24/01/2009, 15h57)
Sur fr.comp.applications.x11, Nicolas George disait :

> C'est bizarre, [snip] ce message n'a plus l'air possible.


Il l'est dans la version 1.4.2, et même dans 1.5.3 :

/*
* xf86FindPrimaryDevice() - Find the display device which
* was active when the server was started.
*/
void
xf86FindPrimaryDevice()
{
/* if no VGA device is found check for primary PCI device */
if (primaryBus.type == BUS_NONE && xorgHWAccess)
CheckGenericGA();
if (primaryBus.type != BUS_NONE) {
char *bus;
char loc[16];

switch (primaryBus.type) {
case BUS_PCI:
bus = "PCI";
snprintf(loc, sizeof(loc), " %2.2x@%2.2x:%2.2x:%1.1x",
primaryBus.id.pci->bus,
primaryBus.id.pci->domain,
primaryBus.id.pci->dev,
primaryBus.id.pci->func);
break;
case BUS_ISA:
bus = "ISA";
loc[0] = '\0';
break;
case BUS_SBUS:
bus = "SBUS";
snprintf(loc, sizeof(loc), " %2.2x", primaryBus.id.sbus.fbNum);
break;
default:
bus = "";
loc[0] = '\0';
}

xf86MsgVerb(X_INFO, 2, "Primary Device is: %s%s\n",bus,loc);
}
}

Le support de ISA a été supprimé le 25/11/08. Voir :
[..]
Nicolas George (24/01/2009, 17h35)
Jogo wrote in message <20090124145715.57b085f3.jogo>:
> Il l'est dans la version 1.4.2, et même dans 1.5.3 :


Dans ce cas, tu devrais essayer avec un snapshot Git pour voir ce que ça
donne.
Discussions similaires
[xorg] Pourquoi type1 n'est plus supporté par xorg ?

[xorg] xfs et xfs-tt sont ils encore utiles, nécessaires, souhaitables...avec xorg ?

Installateur : "xserver-xorg" ou "xserver-xorg-core" ?

repasser de xorg 6.9 à xorg 6.8.2 pour une carte ATI


Fuseau horaire GMT +2. Il est actuellement 10h26. | Privacy Policy