cerhu > microsoft.* > microsoft.dotnet.aspnet

aumeric (17/07/2009, 19h41)
Bonjour à tous
Il m'a fallu réinstaller mon serveur, puis
iis.
Depuis sur tous les sites, impossible d'y accéder depuis internet.
Si je met par défaut par exemple index.htm j'accède au site
mais si je mets index.aspx je n'accède plus et j'ai la page d'erreur me
demandant de
Description : Une erreur d'application s'est produite sur le serveur. Les
paramètres d'erreur personnalisés actuels pour cette application empêchent
l'affichage à distance des détails de l'erreur de l'application (pour des
raisons de sécurité). Cependant, ils peuvent être affichés par les
navigateurs qui s'exécutent sur l'ordinateur serveur local.

Détails: Pour permettre l'affichage des détails de ce message d'erreur
spécifique sur les ordinateurs distants, créez une balise <customErrors>
dans un fichier de configuration « web.config » situé dans le répertoire
racine de l'application Web en cours. Attribuez ensuite la valeur "off" à
l'attribut "mode" de cette balise <customErrors>.

<!-- Web.Config Configuration File -->

<configuration>
<system.web>
<customErrors mode="Off"/>
</system.web>
</configuration>

Remarques: La page d'erreurs actuellement affichée peut être remplacée par
une page d'erreurs personnalisée. Pour ce faire, modifiez l'attribut
"defaultRedirect" de la balise de configuration <customErrors> de
l'application, de sorte qu'il pointe vers une URL de la page d'erreurs
personnalisée.

<!-- Web.Config Configuration File -->

<configuration>
<system.web>
<customErrors mode="RemoteOnly" defaultRedirect="mycustompage.htm"/>
</system.web>
</configuration

pourtant le web config contient bien le customerror mode = off
il n'y a pas de changement sur les sites, et ils fonctionnaient très bien
avant.
J'ai du oublier quelque chose, peut être à configurer dans .net ??
merci de vos lumières
Cordialement
Aumeric
Patrice (18/07/2009, 12h57)
Bonjour,

ASP.NET est-il activé au niveau de IIS. Sinon l'erreur devrait être je pense dans le journal de windows. Sinon voir ce que cela donne directement sur le serveur (la requête étant locale l'erreur devrait être affichée en clair par le navigateur).
aumeric (18/07/2009, 13h44)
Merci Patrice de ta réponse
ASP .net était bien activé mais j'avais juste oublié une broutille lors de
la réinstallation,
euh ... la réinstallation de sqlserveur 2005.
Rien que ca . Il y a des jours où l'on a pas de tête !

Tout fonctionne de nouveau.
Merci pour ton aide.

Cordialement
Aumeric
"Patrice" <http://scribe-fr.blogspot.com/> a écrit dans le message de
news:3724
Bonjour,

ASP.NET est-il activé au niveau de IIS. Sinon l'erreur devrait être je
pense dans le journal de windows. Sinon voir ce que cela donne directement
sur le serveur (la requête étant locale l'erreur devrait être affichée en
clair par le navigateur).
Discussions similaires
[MOSS2007] Page .aspx dans site MOSS

Sites qui acceptent les pad ???

[C# ASPX] Comment faire communiquer une varible de MasterPage a ContentPAgeen aspx

Site web et pages aspx inaccessibles ?


Fuseau horaire GMT +2. Il est actuellement 14h52. | Privacy Policy