cerhu > linux.debian.user.french

Louis-Philippe (02/01/2019, 05h40)
Bonjour,

Je cherche à comprendre pourquoi au démarrage de mon ordinateur, la
connexion PPPOE ne se fait pas automatiquement. Mon ordinateur est un
serveur avec deux interfaces (Wan et Lan), Shorewall est configuré.

Si je fais mon "pon dsl-provider" manuellement, tout fonctionne à
merveille. Par la suite, je dois activer mon Shorewall... pas très pratique
! =)

Lors de la configuration de pppoeconf, j'ai bien coché "activer au
démarrage de l'ordinateur".

Je suis sur une nouvelle installation Debian 9.0. Mes cartes ne s'appellent
plus eth0 et eth1 comme prévu à partir de Stretch. L'interface s'appelle
"enp11s0" ci-dessous.

Voici le syslog au démarrage :
Jan 1 20:27:33 server pppd[840]: Plugin rp-pppoe.so loaded.
Jan 1 20:27:33 server pppd[879]: pppd 2.4.7 started by root, uid 0
Jan 1 20:27:39 server pppd[879]: PPP session is 15569
Jan 1 20:27:39 server pppd[879]: Connected to 00:90:1a:ZZ:XX:YY via
interface enp11s0
Jan 1 20:27:39 server pppd[879]: Using interface ppp0
Jan 1 20:27:39 server pppd[879]: Connect: ppp0 <--> enp11s0
Jan 1 20:27:39 server pppd[879]: Terminating on signal 15
Jan 1 20:27:42 server pppd[879]: Connection terminated.
Jan 1 20:27:42 server pppd[879]: Exit.

Auriez-vous des pistes de solution?

Bonne année 2019 à tous !
Bernard Schoenacker (02/01/2019, 06h00)
----- Mail original -----

> De: "Louis-Philippe" <lpgauthier>
> À: "debian-user-french" <debian-user-french>
> Envoyé: Mercredi 2 Janvier 2019 04:30:01
> Objet: Connexion automatique sur pppoe au démarrage


> Bonjour,


> Je cherche à comprendre pourquoi au démarrage de mon ordinateur, la
> connexion PPPOE ne se fait pas automatiquement. Mon ordinateur est
> un serveur avec deux interfaces (Wan et Lan), Shorewall est
> configuré.


> Si je fais mon "pon dsl-provider" manuellement, tout fonctionne à
> merveille. Par la suite, je dois activer mon Shorewall... pas très
> pratique ! =)


> Lors de la configuration de pppoeconf, j'ai bien coché "activer au
> démarrage de l'ordinateur".


> Je suis sur une nouvelle installation Debian 9.0. Mes cartes ne
> s'appellent plus eth0 et eth1 comme prévu à partir de Stretch.
> L'interface s'appelle "enp11s0" ci-dessous.


> Voici le syslog au démarrage :
> Jan 1 20:27:33 server pppd[840]: Plugin rp-pppoe.so loaded.
> Jan 1 20:27:33 server pppd[879]: pppd 2.4.7 started by root, uid 0
> Jan 1 20:27:39 server pppd[879]: PPP session is 15569
> Jan 1 20:27:39 server pppd[879]: Connected to 00:90:1a:ZZ:XX:YY via
> interface enp11s0
> Jan 1 20:27:39 server pppd[879]: Using interface ppp0
> Jan 1 20:27:39 server pppd[879]: Connect: ppp0 <--> enp11s0
> Jan 1 20:27:39 server pppd[879]: Terminating on signal 15
> Jan 1 20:27:42 server pppd[879]: Connection terminated.
> Jan 1 20:27:42 server pppd[879]: Exit.


> Auriez-vous des pistes de solution?


> Bonne année 2019 à tous !


bonjour,

voici un début de piste :

# [..]

# [..]

# [..]

# [..]

merci

slt

bernard
Pascal Hambourg (02/01/2019, 21h10)
Le 02/01/2019 à 04:30, Louis-Philippe a écrit :
[..]
> Jan 1 20:27:39 server pppd[879]: PPP session is 15569
> Jan 1 20:27:39 server pppd[879]: Connected to 00:90:1a:ZZ:XX:YY via
> interface enp11s0
> Jan 1 20:27:39 server pppd[879]: Using interface ppp0
> Jan 1 20:27:39 server pppd[879]: Connect: ppp0 <--> enp11s0
> Jan 1 20:27:39 server pppd[879]: Terminating on signal 15
> Jan 1 20:27:42 server pppd[879]: Connection terminated.
> Jan 1 20:27:42 server pppd[879]: Exit.
> Auriez-vous des pistes de solution?


Tu peux essayer d'ajouter l'option "debug" dans
/etc/ppp/peers/dsl-providers pour rendre pppd plus bavard.
L'option "persist" pour la reconnexion automatique est bien présente ?
Que contient /etc/network/interfaces ?
Louis-Philippe (03/01/2019, 04h40)
Bonjour,

Voici l'information demandée :
Oui, l'option persist est là dans le dsl-provider.

Voici mon fichier /etc/network/interfaces:
-----------------------------------------
# This file describes the network interfaces available on your system
# and how to activate them. For more information, see interfaces(5).

source /etc/network/interfaces.d/*

# The loopback network interface
auto lo
iface lo inet loopback

auto eno1
iface eno1 inet static
address 192.168.0.1
netmask 255.255.255.0
gateway 192.168.0.1

auto dsl-provider
iface dsl-provider inet ppp
pre-up /bin/ip link set enp11s0 up # line maintained by pppoeconf
provider dsl-provider

auto enp11s0
iface enp11s0 inet manual

et un cat syslog | grep pppd (au démarrage):
------------------------------------------
Jan 2 20:45:14 garfield pppd[737]: Plugin rp-pppoe.so loaded.
Jan 2 20:45:14 garfield pppd[774]: pppd 2.4.7 started by root, uid 0
Jan 2 20:45:14 garfield pppd[774]: Send PPPOE Discovery V1T1 PADI session
0x0 length 4
Jan 2 20:45:14 garfield pppd[774]: dst ff:ff:ff:ff:ff:ff src
40:2c:f4:e9:ad:e5
Jan 2 20:45:14 garfield pppd[774]: [service-name]
Jan 2 20:45:19 garfield pppd[774]: Send PPPOE Discovery V1T1 PADI session
0x0 length 4
Jan 2 20:45:19 garfield pppd[774]: dst ff:ff:ff:ff:ff:ff src
40:2c:f4:e9:ad:e5
Jan 2 20:45:19 garfield pppd[774]: [service-name]
Jan 2 20:45:19 garfield pppd[774]: Recv PPPOE Discovery V1T1 PADO session
0x0 length 42
Jan 2 20:45:19 garfield pppd[774]: dst 40:2c:f4:e9:ad:e5 src
00:90:1a:a1:e9:60
Jan 2 20:45:19 garfield pppd[774]: [AC-name bas12-quebec14]
[service-name] [AC-cookie ed 75 43 33 67 cd ba 46 2f f1 29 b4 d8 83 58 7f]
Jan 2 20:45:19 garfield pppd[774]: Send PPPOE Discovery V1T1 PADR session
0x0 length 24
Jan 2 20:45:19 garfield pppd[774]: dst 00:90:1a:a1:e9:60 src
40:2c:f4:e9:ad:e5
Jan 2 20:45:19 garfield pppd[774]: [service-name] [AC-cookie ed 75 43 33
67 cd ba 46 2f f1 29 b4 d8 83 58 7f]
Jan 2 20:45:19 garfield pppd[774]: Recv PPPOE Discovery V1T1 PADS session
0x160 length 4
Jan 2 20:45:19 garfield pppd[774]: dst 40:2c:f4:e9:ad:e5 src
00:90:1a:a1:e9:60
Jan 2 20:45:19 garfield pppd[774]: [service-name]
Jan 2 20:45:19 garfield pppd[774]: PADS: Service-Name: ''
Jan 2 20:45:19 garfield pppd[774]: PPP session is 352
Jan 2 20:45:19 garfield pppd[774]: Connected to 00:90:1a:a1:e9:60 via
interface enp11s0
Jan 2 20:45:19 garfield pppd[774]: using channel 1
Jan 2 20:45:19 garfield pppd[774]: Using interface ppp0
Jan 2 20:45:19 garfield pppd[774]: Connect: ppp0 <--> enp11s0
Jan 2 20:45:19 garfield pppd[774]: sent [LCP ConfReq id=0x1 <mru 1492>
<magic 0x23d904e7>]
Jan 2 20:45:19 garfield pppd[774]: Terminating on signal 15
Jan 2 20:45:19 garfield pppd[774]: sent [LCP TermReq id=0x2 "User request"]
Jan 2 20:45:19 garfield pppd[774]: rcvd [LCP ConfReq id=0xf0 <mru 1492>
<auth pap> <magic 0x6a061166>]
Jan 2 20:45:19 garfield pppd[774]: rcvd [LCP ConfAck id=0x1 <mru 1492>
<magic 0x23d904e7>]
Jan 2 20:45:22 garfield pppd[774]: sent [LCP TermReq id=0x3 "User request"]
Jan 2 20:45:22 garfield pppd[774]: rcvd [LCP TermAck id=0x3]
Jan 2 20:45:22 garfield pppd[774]: Connection terminated.
Jan 2 20:45:22 garfield pppd[774]: Exit.

Merci pour votre aide.

Le mer. 2 janv. 2019, à 14 h 01, Pascal Hambourg <pascal> a
écrit :
[..]
Sébastien NOBILI (03/01/2019, 11h20)
Bonjour,

Je ne connais pas (plus) PPPOE et PPPD, mais :

Le mercredi 02 janvier 2019 à 21:37, Louis-Philippe a écrit :
> Jan 2 20:45:19 garfield pppd[774]: Terminating on signal 15


Ton processus reçoit un signal 15 (SIGTERM), c?est donc qu?il est arrêté par un
autre processus (Systemd via networking.service ?). Tu trouveras peut-être une
explication dans les logs du processus en question.

Sébastien
Pascal Hambourg (03/01/2019, 21h50)
Le 03/01/2019 à 03:37, Louis-Philippe a écrit :
> Voici mon fichier /etc/network/interfaces: (...)
> auto dsl-provider
> iface dsl-provider inet ppp
> pre-up /bin/ip link set enp11s0 up # line maintained by pppoeconf
> provider dsl-provider
> auto enp11s0
> iface enp11s0 inet manual


J'aurais placé la définition d'enp11s0 avant celle de dsl-provider.

> et un cat syslog | grep pppd (au démarrage):
> ------------------------------------------

La découverte du concentrateur d'accès PPPoE et l'établissement de la
session PPPoE se passent bien. Le début de la négociation de la session
PPP aussi, jusqu'à ce que pppd soit interrompu par un signal SIGTERM. Il
termine proprement la session PPP avec le pair et sort.

> Jan 2 20:45:19 garfield pppd[774]: Terminating on signal 15


A noter que le même message se produit lorsqu'on arrête la session PPP
avec poff ou ifdown. Mais je ne vois pas ce qui peut exécuter poff ou
ifdown à ce stade. Quelqu'un a évoqué le service networking, mais au
démarrage il ne fait qu'exécuter ifup -a pour démarrer les interfaces
marquées "auto".
Louis-Philippe (04/01/2019, 01h30)
Bonjour,
J'ai trouvé ça dans syslog...

Jan 3 18:08:05 garfield pppd[846]: Plugin rp-pppoe.so loaded.
Jan 3 18:08:05 garfield ifup[639]: Plugin rp-pppoe.so loaded.

pppd et ifup charge deux fois le module en même temps ?

Le jeu. 3 janv. 2019, à 04 h 11, Sébastien NOBILI <sebnewsletter> a
écrit :
[..]
Pascal Hambourg (04/01/2019, 01h50)
Le 04/01/2019 à 00:25, Louis-Philippe a écrit :
> J'ai trouvé ça dans syslog...
> Jan 3 18:08:05 garfield pppd[846]: Plugin rp-pppoe.so loaded.
> Jan 3 18:08:05 garfield ifup[639]: Plugin rp-pppoe.so loaded.
> pppd et ifup charge deux fois le module en même temps ?


Non, je suppose que c'est pppd qui a écrit ça sur sa sortie standard (ou
d'erreur) avant de se démoniser, et ça se retrouve dans la sortie d'ifup
qui a invoqué pppd.
Louis-Philippe (05/01/2019, 21h00)
Bonjour,

Est-ce que Network-Manager peut avoir laisser des traces dans la
configuration ?
Bien que c'est un serveur, j'ai installé un interface graphique. Je mesuis
aperçu que Network-manager causait des problèmes...

Bonne journée

Le jeu. 3 janv. 2019, à 18 h 41, Pascal Hambourg <pascal> a
écrit :
[..]
Pascal Hambourg (05/01/2019, 23h10)
Le 05/01/2019 à 19:57, Louis-Philippe a écrit :
> Est-ce que Network-Manager peut avoir laisser des traces dans la
> configuration ?


Normalement, la configuration par défaut de NetworkManager dans
/etc/NetworkManager/NetworkManager.conf lui dit de ne pas s'occuper des
interfaces définies dans /etc/network/interfaces.
----------->8
[main]
plugins=ifupdown,keyfile

[ifupdown]
managed=false
----------->8

Tu n'as pas créé de connexion PPPoE (DSL) dans NetworkManager ni de
configuration pour l'interface ethernet support de PPPoE, n'est-ce pas ?

> Bien que c'est un serveur, j'ai installé un interface graphique. Je me suis
> aperçu que Network-manager causait des problèmes...


De quel genre ?
Discussions similaires
démarrage automatique pppoe

Connexion automatique au démarrage

Connexion automatique au démarrage

Connexion automatique au démarrage


Fuseau horaire GMT +2. Il est actuellement 17h47. | Privacy Policy