cerhu > linux.debian.user.french

Stephane Ascoet (15/01/2019, 12h50)
Le 14/01/2019 à 15:01, Jean Bernon a écrit :

> - le script est en sh et le test de la version de gnome installée ne fonctionne pas avec bash (merci à Stéphane Ascoët). J'ai remplacé le test par "VER=3.22.2".


Bonjour, le bug ne vient pas d'une difference entre generations de
Shells mais d'un code qui ne respecte pas les bonnes pratiques. Il
applique sur le numero de version un Sed dont je ne vois pas l'utilite,
sans doute une autre vieille survivance. En fait, le script a quasiment
ete vide pour Buster. Ce qui signifie que mon depot de bug sera rejete.

> - la commande "gnome-session --choose-session=openbox-session" est obsolète, je l'ai remplacée par "gnome-session --session=openbox-gnome"


Ce que je ne comprends pas, c'est que si tu as une version 3, cette
partie de code n'est pas executee. Ce sont justement ces deux blocs
gerant les versions anterieures a "3" qui ont ete retires dans la
version de Buster. Ainsi donc il y a bien des paquets non-fonctionnels
dans les Debian stables :-( M'enfin ce n'est pas aussi grave que le
noyau bugge de la Etch qui provoquait des pertes de donnees :'-(

> - ensuite la commande gnome-session cherche le fichier "openbox.desktop" qu'elle cherche dans divers répertoires, mais pas dans les deux où se trouve un fichier de ce nom /usr/share/gnome/wm-properties/ et /usr/share/xsessions/. J'ai copié tour à tour dans $HOME/.config/autostart chacun des deux fichiers qui sont différents et aboutissent au même résultat.


Ces deux fichiers sont justement installes par le paquet semble t-il.
Jean Bernon (15/01/2019, 13h30)
----- Mail original -----

> De: "Stephane Ascoet" <stephane.ascoet>
> À: "debian-user-french" <debian-user-french>
> Envoyé: Mardi 15 Janvier 2019 11:48:41
> Objet: Re: Gnome-openbox [résolu ?]


> Le 14/01/2019 à 15:01, Jean Bernon a écrit :


> > - la commande "gnome-session --choose-session=openbox-session" est
> > obsolète, je l'ai remplacée par "gnome-session
> > --session=openbox-gnome"


> Ce que je ne comprends pas, c'est que si tu as une version 3, cette
> partie de code n'est pas executee. Ce sont justement ces deux blocs
> gerant les versions anterieures a "3" qui ont ete retires dans la
> version de Buster. Ainsi donc il y a bien des paquets
> non-fonctionnels
> dans les Debian stables :-( M'enfin ce n'est pas aussi grave que le
> noyau bugge de la Etch qui provoquait des pertes de donnees :'-(


Tu as raison. J'ai mal interprété le script. Ce changement était inutile. Dans le cas d'une version 3 le script se résume à son avant-dernière ligne "exec gnome-session --session=openbox-gnome"....

> > - ensuite la commande gnome-session cherche le fichier
> > "openbox.desktop" qu'elle cherche dans divers répertoires, mais
> > pas dans les deux où se trouve un fichier de ce nom
> > /usr/share/gnome/wm-properties/ et /usr/share/xsessions/. J'ai
> > copié tour à tour dans $HOME/.config/autostart chacun des deux
> > fichiers qui sont différents et aboutissent au même résultat.


> Ces deux fichiers sont justement installes par le paquet semble t-il.


Curieux qu'ils soient installés dans des répertoires que gnome-session ignore...

Discussions similaires
Mettre Gnome 3.26 sur Ubuntu Gnome 16.04.3 : possible ? Bonne ou mauvaise idée ?

Menu Openbox

openbox et composant xfce

Probleme avec startx et openbox


Fuseau horaire GMT +2. Il est actuellement 20h30. | Privacy Policy