cerhu > linux.debian.user.french

Yves Rutschle (28/01/2019, 17h40)
On Mon, Jan 28, 2019 at 03:40:15PM +0100, Stephane Ascoet wrote:
> > Comme toujours en cas de suspicion de compromission, la seule méthode
> > fiable est la réinstallation.

> Sur la liste Devuan, ils ont dit que telecharger le paquet apt manuellement
> depuis les depots etait une solution possible.


Solution à quoi? Un attaquant qui se serait amusé à faire
une attaque MitM pour pourrir ton APT, y'a quand même de
bonnes chances pour qu'il ai installé une backdoor ailleurs
dans ton système, non?

Y.
Pascal Hambourg (28/01/2019, 22h40)
Le 28/01/2019 à 15:40, Stephane Ascoet a écrit :
> Sur la liste Devuan, ils ont dit que telecharger le paquet apt
> manuellement depuis les depots etait une solution possible.


A condition de vérifier l'authenticité du fichier, parce qu'un MitM est
encore plus facile à réaliser sur une connexion HTTP entre un navigateur
et un serveur web.

> Ils ont
> aussi indique l'adresse du depot principal qui ne connait aucune
> redirection et ne peut dont pas etre un vecteur


Le site originel n'a pas besoin de faire une redirection pour que la
faille soit exploitable. Le principe du MitM est que l'attaquant se
substitue au site originel, donc il peut répondre n'importe quoi.
ajh-valmer (29/01/2019, 18h50)
On Monday 28 January 2019 16:19:27 Yves Rutschle wrote:
> Solution à quoi? Un attaquant qui se serait amusé à faire
> une attaque MitM pour pourrir ton APT, y'a quand même de
> bonnes chances pour qu'il ai installé une backdoor ailleurs
> dans ton système, non?


Sauf erreur,
Je n'ai pas vu la méthode idoine pour upgrader apt,
de 1.4.8 vers 1.4.9.

A. Valmer
Bernard Schoenacker (29/01/2019, 18h50)
> Sauf erreur,
> Je n'ai pas vu la méthode idoine pour upgrader apt,
> de 1.4.8 vers 1.4.9.
> A. Valmer bonjour,


tout es expliqué sur ce site :
[..]

voici ce qu'il faut retenir :

apt -o Acquire::http::AllowRedirect=false update;
apt -o Acquire::http::AllowRedirect=false upgrade

modifier le fichier sources.list et mettre ceci:

[..]

Bulletin de sécurité Debian du 22 janvier 2019 :

[..]

merci

slt
bernard
roger.tarani (30/01/2019, 14h50)
Bonjour
avec une machine encore en Jessie qui a une version plus ancienne de apt,
en plus de la mani expliquée, est-il possible de passer simplement à une version de apt >= 1.4.9 et sans créer d'autres problèmes ?
Merci

----- Original Message -----
[..]
Yves Rutschle (30/01/2019, 15h50)
On Tue, Jan 29, 2019 at 05:42:58PM +0100, ajh-valmer wrote:
> Je n'ai pas vu la méthode idoine pour upgrader apt,
> de 1.4.8 vers 1.4.9.


Ce que je dis, c'est que le problème n'est pas dans la mise
à jour d'APT. Si ton système a fait l'objet d'une attaque,
alors l'attaquant a pu utiliser APT pour installer ce qu'il
veut. Peu importe que l'on mette ensuite à jour APT. Et la
seule contre-mesure face à ça, c'est la réinstallation
complète car tu ne peux plus avoir confiance en rien dans
ton système.

(Après, faut pas non plus psychoter: l'attaquant doit quand
même avoir été capable de se placer entre ton système et le
repository que tu utilises.)

Y.
Étienne Mollier (30/01/2019, 15h50)
On 1/30/19 1:46 PM, roger.tarani wrote:
> Bonjour
> avec une machine encore en Jessie qui a une version plus ancienne de apt,
> en plus de la mani expliquée, est-il possible de passer simplement à une version de apt >= 1.4.9 et sans créer d'autres problèmes ?
> Merci


Bonjour,

Oui, c'est possible. Pour Jessie la version apportant les
correctifs est la 1.0.9.8.5. Voir :

[..]

Amicalement,
Étienne Mollier (30/01/2019, 16h00)
Moi-même, à l'instant:
> On 1/30/19 1:46 PM, roger.tarani wrote:
> > est-il possible de passer simplement à une version de
> > apt >= 1.4.9 [...]

> Oui, c'est possible....


Hum, à la relecture, j'aurais dû me contenter de dire que apt,
version 1.0.9.8.5, corrige le problème en Jessie; il y a matière
à comprendre mon message initial de travers.

Amicalement,
ajh-valmer (30/01/2019, 20h30)
> > Sauf erreur,
> > Je n'ai pas vu la méthode idoine pour upgrader apt,
> > de 1.4.8 vers 1.4.9.


> tout es expliqué sur ce site :
> [..]
> apt -o Acquire::http::AllowRedirect=false update;
> apt -o Acquire::http::AllowRedirect=false upgrade
> modifier le fichier sources.list et mettre ceci:
> [..]
> [..]


Choses que je n'ai pas faites...

Mais, de toutes façons, bien d'autres comme moi
avaient utilisé avant apt version 1.4.8,
donc possibilité de contamination.

Un rkhunter (rootkit) sur mon DD a donné un résultat négatif.
Pascal Hambourg (30/01/2019, 21h20)
Le 30/01/2019 à 19:22, ajh-valmer a écrit :
>> apt -o Acquire::http::AllowRedirect=false update;
>> apt -o Acquire::http::AllowRedirect=false upgrade
>> modifier le fichier sources.list et mettre ceci:
>> [..]
>> [..]

> Choses que je n'ai pas faites...


Ton système est donc potentiellement compromis.

> Mais, de toutes façons, bien d'autres comme moi
> avaient utilisé avant apt version 1.4.8,
> donc possibilité de contamination.


A une différence près : c'était avant la publication de la faille, donc
son exploitation serait un "0-day". Après la publication de la faille,
le risque de tentative d'exploitation augmente.

Discussions similaires
Alerte de Sécurité ?

Alerte de sécurité

Alerte de sécurité...

Alerte sécurité


Fuseau horaire GMT +2. Il est actuellement 12h27. | Privacy Policy