cerhu > linux.debian.user.french

Bernard Schoenacker (24/02/2019, 18h50)
bonjour,

qui pourrais me donner un coup de pouce pour que je
puisse comprendre l'art et la manière d'utiliser
freecad ?

merci de votre aimable attention

slt
bernard
Belaïd (24/02/2019, 19h40)
Bonjour,

Tu as plein de tutoriel par exemple sur YouTube qui sont pas mal pour
débuter. As tu essayé ?

Le dim. 24 févr. 2019 17:44, Bernard Schoenacker <
bernard.schoenacker> a écrit :
[..]
contact (24/02/2019, 19h50)
Bonsoir

pas facile de fournir une réponse simple à cette question. Quelles sont
vos connaissances dans ce domaine, quels sont vos attentes ?

Cordialement

François-Marie BILLARD

Le 24/02/2019 à 18:35, Belaïd a écrit :
[..]
ajh-valmer (24/02/2019, 21h30)
On Sunday 24 February 2019 17:44:10 Bernard Schoenacker wrote:
> qui pourrait me donner un coup de pouce pour que je
> puisse comprendre l'art et la manière d'utiliser freecad ?
> merci de votre aimable attention
> slt bernard


Suffit de taper sous Google "tutoriels freecad",
ou de s'inscrire à une école de mécanique...
:-)
Benoit B (03/03/2019, 18h50)
Bonjour,

Pourquoi ne pas poster sur le forum francophone de freecad ?

[..]

Dans ta situation, je listerais les usages que je veux en faire pour
déterminer avec quels ateliers je dois me familiariser...
[..]

Il me semble qu'un point d'entrée généraliste est l'atelier esquisses.
[..]
Perso j'ai commencé par ce tuto :
[..]
Il initie à l'atelier esquisses qui va servir à la conception d'une
pièce dans Part Design...

Aussi j'installerais Freecad soit en testing pour avoir la version
0.17 de ce tuto (la version stable de freecad en paquet debian est la
0.16) soit via une Appimage...
[..]

Benoit

Le dim. 24 févr. 2019 à 20:21, ajh-valmer <ajh.valmer> a écrit :
[..]
BERTRAND Joël (04/03/2019, 09h20)
Benoit B a écrit :
[..]
> [..]
> Perso j'ai commencé par ce tuto :
> [..]
> Il initie à l'atelier esquisses qui va servir à la conception d'une
> pièce dans Part Design...
> Aussi j'installerais Freecad soit en testing pour avoir la version
> 0.17 de ce tuto (la version stable de freecad en paquet debian est la
> 0.16) soit via une Appimage...
> [..]


Bonjour,

Pour utiliser FreeCAD avec un tôlier (donc pour des vraies pièces pas
pour la beauté du sport), il vaut mieux utiliser la version de
développement en la compilant depuis le dépôt git car l'outil est plein
de bugs rigolos (en particulier la destruction des contraintes lorsqu'on
modifie une esquisse d'une pièce). Ça se compile relativement bien mais
il faut prendre garde à compiler une version "release" et non une
version "dev" inutilisable sur des pièces un peu complexes (les routines
de debug font ramer l'outil à mort).

Bien cordialement,

JB
Benoit B (04/03/2019, 15h30)
Le lun. 4 mars 2019 à 08:13, BERTRAND Joël <joel.bertrand> a écrit :
> Benoit B a écrit :
> > Aussi j'installerais Freecad soit en testing pour avoir la version
> > 0.17 de ce tuto (la version stable de freecad en paquet debian est la
> > 0.16) soit via une Appimage...


J'en profite pour me corriger, ma formulation induit en erreur :
Je voulais écrire : La version de freecad en paquet debian stable est
la 0.16, or la version stable de freecad est la 0.17 qui est
disponible en debian testing ou en Appimage...

> Bonjour,
> Pour utiliser FreeCAD avec un tôlier (donc pour des vraies pièces pas
> pour la beauté du sport), il vaut mieux utiliser la version de
> développement en la compilant depuis le dépôt git car l'outil est plein
> de bugs rigolos (en particulier la destruction des contraintes lorsqu'on
> modifie une esquisse d'une pièce). Ça se compile relativement bien mais
> il faut prendre garde à compiler une version "release" et non une
> version "dev" inutilisable sur des pièces un peu complexes (les routines
> de debug font ramer l'outil à mort).


Bonjour,

Je n'ai pas bien compris...
d52fr (04/03/2019, 15h40)
Bonjour,Le FullCircleMagazine a consacré plusieurs articles sur la prise en main de Freecad à travers quelques tutoriels.À voir dans les numéros 120 à 129.[..] Rubrique : Lire et télécharger les numéros
Cordialement

Le lundi 4 mars 2019 à 14:25:52 UTC+1, Benoit B <benoitlst> a écrit :
Le lun. 4 mars 2019 à 08:13, BERTRAND Joël <joel.bertrand> a écrit :
> Benoit B a écrit :
> > Aussi j'installerais Freecad soit en testing pour avoir la version
> > 0.17 de ce tuto (la version stable de freecad en paquet debian est la
> > 0.16) soit via une Appimage...


J'en profite pour me corriger, ma formulation induit en erreur :
Je voulais écrire : La version de freecad en paquet debian stable est
la 0.16, or la version stable de freecad est la 0.17 qui est
disponible en debian testing ou en Appimage...

>        Bonjour,
>        Pour utiliser FreeCAD avec un tôlier (donc pour des vraies pièces pas
> pour la beauté du sport), il vaut mieux utiliser la version de
> développement en la compilant depuis le dépôt git car l'outil est plein
> de bugs rigolos (en particulier la destruction des contraintes lorsqu'on
> modifie une esquisse d'une pièce). Ça se compile relativement bien mais
> il faut prendre garde à compiler une version "release" et non une
> version "dev" inutilisable sur des pièces un peu complexes (les routines
> de debug font ramer l'outil à mort).


Bonjour,

Je n'ai pas bien compris...
BERTRAND Joël (04/03/2019, 16h10)
Benoit B a écrit :
> Le lun. 4 mars 2019 à 08:13, BERTRAND Joël <joel.bertrand> a écrit :
> J'en profite pour me corriger, ma formulation induit en erreur :
> Je voulais écrire : La version de freecad en paquet debian stable est
> la 0.16, or la version stable de freecad est la 0.17 qui est
> disponible en debian testing ou en Appimage...
>> Bonjour,

> Je n'ai pas bien compris...

FreeCAD contient un certain nombre de bugs, voire un nombre certain, le
développement est continuel. Utiliser une version 0.16 ou 0.17 alors
qu'on a sous la main une 0.18 et bientôt une 0.19 est dangereux. Lorsque
tu utilises _vraiment_ FreeCAD, tu t'aperçois rapidement que la 0.17 est
inutilisable car n'importe quelle modification d'esquisse dans une pièce
te vire au hasard les points contraints ou les faces de projections des
esquisses suivantes de l'arborescence et tu te retrouves avec des
palanquées d'esquisses qui sont marquées en défaut. J'ai assez perdu de
boulot avec la version 0.17 pour suivre le git. Ce n'est pas pire.

Et lorsqu'on compile depuis le git, il faut rajouter l'option pour
avoir une compilation en mode release et non debug (sinon, le solver des
esquisses, entre autres, rame à mort dès que tes esquisses sont un peu
compliquées.). C'est indiqué noir sur blanc dans la doc. Par défaut (à
moins que cela n'ait changé récemment), c'est une version debug qui est
compilée.

JB
Benoit B (04/03/2019, 17h50)
Salut,

Merci pour l'info, tu m'as donné envie d'essayer de compiler la version 0.18...

Le lun. 4 mars 2019 à 15:04, BERTRAND Joël <joel.bertrand> a écrit :
[..]
Benoit B (04/03/2019, 18h40)
> Et lorsqu'on compile depuis le git, il faut rajouter l'option pour
> avoir une compilation en mode release et non debug (sinon, le solver des
> esquisses, entre autres, rame à mort dès que tes esquisses sontun peu
> compliquées.). C'est indiqué noir sur blanc dans la doc. Par défaut (à
> moins que cela n'ait changé récemment), c'est une version debugqui est
> compilée.


Pour certains paquets debian nécessaires à la compilation, je ne
trouve pas leur équivalant en python3 et Qt5
Cf.
[..]

Vu qu'ils recommandent d'utiliser python3 et Qt5 plutôt que python2 etQt4
Cf.
[..]

Ex:libqt4-dev Je ne trouves pas d'équivalant libqt5-dev

Aurais-tu la liste des paquets debian à installer avec python3 et Qt5 ?

Merci d'avane
BERTRAND Joël (06/03/2019, 19h10)
Benoit B a écrit :
> Pour certains paquets debian nécessaires à la compilation, je ne
> trouve pas leur équivalant en python3 et Qt5
> Cf.
> [..]
> Vu qu'ils recommandent d'utiliser python3 et Qt5 plutôt que python2 et Qt4
> Cf.
> [..]
> Ex:libqt4-dev Je ne trouves pas d'équivalant libqt5-dev
> Aurais-tu la liste des paquets debian à installer avec python3 et Qt5 ?


Je l'ai compilé avec python 2.7 et qt4. Ça fonctionne.

Bien cordialement,

JKB
Discussions similaires
Prise en main à distance

Prise en main

prise de main a distance en php

[WD9] Prise en main


Fuseau horaire GMT +2. Il est actuellement 03h30. | Privacy Policy