cerhu > linux.debian.user.french

Benoit B (27/04/2019, 20h10)
Bonjour,

Sur mon ordi portable, j?utilise l'ACPI pour programmer les touchesde
fonction (volume sonore, mute et rétroéclairage).

J'ai installé : acpid qui installe acpi-support-base en dépendence.

Quand on presse la touche de fonction pour augmenter le
rétro-éclairage, acpi_listen doit afficher un truc du genre :

video/brightnessup BRTUP 00000086 000000

"video/brightnessup" est le nom de l'évènement à intercepteret qui
appelle un script qui incrémente :
/sys/class/backlight/intel_backlight/brightness

D'un minimum (pour ne pas avoir un écran noir) à un maximum indiqué dans :
/sys/class/backlight/intel_backlight/max_brightness

Dans /etc/acpi/events/ je place les fichiers brightness-down et
brightness-up qui appellent le script (brightness.sh) ainsi :
---------------------------------------------
# /etc/acpi/events/brightness-up

event=video[ /]brightnessup
action=/etc/acpi/actions/brightness.sh up
---------------------------------------------
Ca a toujours bien fonctionné sur deux portables (celui d?avant et
d?encore avant).

Mais sur celui-ci, les évènements brightness(up et down) cessent de
fonctionner à la sortie d?une mise en veille (alors que volume(up et
down) continuent à fonctionner).

Le script de rétroéclairage n?est donc pas appelé, (mais si je
l?appelle en ligne de commande, ça fonctionne).

J?ai beau redémarrer acpid :
systemctl restart acpid.socket
systemctl restart acpid.path
systemctl restart acpid.service

J?ai essayé de redémarrer tout ce que je trouve pour être sûr?

Ca ne fonctionne pas (sauf si je reboot et seulement jusqu?à la
prochaine mise en veille).

Quelqu?un a une idée ?

Merci d?avance

?
Benoit
Haricophile (29/04/2019, 09h10)
Le samedi 27 avril 2019 à 20:04 +0200, Benoit B a écrit :
> Quelqu?un a une idée ?


Une histoire d'ordre dans la séquence de démarrage de systemD ?
Benoit B (29/04/2019, 09h40)
Le lun. 29 avr. 2019 à 09:07, Haricophile <haricophile> a écrit :
> Le samedi 27 avril 2019 à 20:04 +0200, Benoit B a écrit :
> > Quelqu?un a une idée ?

> Une histoire d'ordre dans la séquence de démarrage de systemD ?

Ha chouette piste ! Je n'y avais pas pensé !
D'autant plus probable qu'après un reboot le service n'est pas opérationnel et
que je dois le démarrer :
systemctl start acpid.service
J'avais oublié de le signaler...
Depuis init, je n'ai jamais appris systemD.
Comment puis-je essayer de résoudre le problème ?

Merci d'avance,
Discussions similaires
Sortie de mise en veille prolongée...

Sortie de la mise en veille

[SP2] Sortie de la mise en veille : plus de réseau.

Sortie de mise en veille


Fuseau horaire GMT +2. Il est actuellement 01h41. | Privacy Policy