cerhu > linux.debian.user.french

BERTRAND Joël (03/06/2019, 18h20)
Bonsoir à tous,

J'espère qu'il y a par ici des gens qui utilisent Alfresco... Cet outil
est puissant, mais qu'est-ce que son installation est merdouillique.

Bref. L'an passé, j'ai réussi à installer Alfresco CE 6.0 sur un tomcat
8.5. Ça tournait raisonnablement bien. On m'a demandé de passer à la
version 6.1 avant une montée en charge. Vue l'expérience de
l'installation que j'avais, j'ai donc fait une sauvegarde de la base de
donnée (PostgreSQL 10) et du système de fichiers d'Alfesco. J'ai suivi
_scrupuleusement_ la doc de mise à jour. Naturellement, ça ne fonctionne
pas.

Tomcat se lance, java mouline, dans les logs de tomcat, je vois au bout
d'une grosse minute que alfresco et share (les deux servlets en
question) sont lancés. Mais lorsque je tente une connexion sur
<ip>:8080, ça mouline et ça termine sur un timeout.

Je viens de passer deux jours à essayer de comprendre ce qui coince. Je
n'ai rien d'étrange dans les logs. Je suis donc reparti d'une table rase :
- tomcat 9 (avec solr)
- java 11 (openjdk version "11.0.3" 2019-04-16)
- PostgreSQL 11
- alfresco CE 6.1

J'ai donc effectué une installation et non une mise à jour. Le résultat
est _strictement_ le même. Timeout de connexion. Pourtant les différents
fichiers war sont déployés correctement, je n'ai aucune erreur dans les
logs :

[2019-06-03 17:56:52] [info] juin 03, 2019 5:56:52 PM
org.artofsolving.jodconverter.office.OfficeConnect ion connect
[2019-06-03 17:56:52] [info] INFOS: connected:
'socket,host=127.0.0.1,port=2022,tcpNoDelay=1'
[2019-06-03 17:56:52] [info] 2019-06-03 17:56:52,915 INFO
[management.subsystems.ChildApplicationContextFacto ry] [main] Startup of
'OOoJodconverter' subsystem, ID: [OOoJodconverter, default] complete
[2019-06-03 17:56:52] [info] 2019-06-03 17:56:52,917 INFO
[repo.admin.ConfigurationChecker] [main] The root data directory
('dir.root') is: /opt/alfresco-data
[2019-06-03 17:56:52] [info] 2019-06-03 17:56:52,937 INFO
[admin.patch.PatchExecuter] [main] Checking for patches to apply ...
[2019-06-03 17:56:53] [info] 2019-06-03 17:56:53,136 INFO
[admin.patch.PatchExecuter] [main] No patches were required.
[2019-06-03 17:56:53] [info] 2019-06-03 17:56:53,150 INFO
[repo.module.ModuleServiceImpl] [main] Found 4 module package(s).
[2019-06-03 17:56:53] [info] 2019-06-03 17:56:53,198 INFO
[repo.module.ModuleServiceImpl] [main] Starting module
'de.fme.alfresco.JavascriptConsole-share' version 0.6.1604291213.
[2019-06-03 17:56:53] [info] 2019-06-03 17:56:53,241 INFO
[repo.module.ModuleServiceImpl] [main] Starting module
'de.fme.alfresco.JavascriptConsole-repo' version 0.6.1604291213.
[2019-06-03 17:56:53] [info] 2019-06-03 17:56:53,282 INFO
[repo.module.ModuleServiceImpl] [main] Starting module
'alfresco-share-services' version 6.1.0.
[2019-06-03 17:56:53] [info] 2019-06-03 17:56:53,322 INFO
[repo.module.ModuleServiceImpl] [main] Starting module
'alfresco-trashcan-cleaner' version 2.3.
[2019-06-03 17:56:53] [info] 2019-06-03 17:56:53,342 INFO
[management.subsystems.ChildApplicationContextFacto ry] [main] Starting
'fileServers' subsystem, ID: [fileServers, default]
[2019-06-03 17:56:53] [info] 2019-06-03 17:56:53,693 INFO
[management.subsystems.ChildApplicationContextFacto ry] [main] Startup of
'fileServers' subsystem, ID: [fileServers, default] complete
[2019-06-03 17:56:53] [info] 2019-06-03 17:56:53,693 INFO
[management.subsystems.ChildApplicationContextFacto ry] [main] Starting
'imap' subsystem, ID: [imap, default]
[2019-06-03 17:56:53] [info] 2019-06-03 17:56:53,761 INFO
[management.subsystems.ChildApplicationContextFacto ry] [main] Startup of
'imap' subsystem, ID: [imap, default] complete
[2019-06-03 17:56:53] [info] 2019-06-03 17:56:53,761 INFO
[management.subsystems.ChildApplicationContextFacto ry] [main] Starting
'email' subsystem, ID: [email, outbound]
[2019-06-03 17:56:53] [info] 2019-06-03 17:56:53,951 INFO
[management.subsystems.ChildApplicationContextFacto ry] [main] Startup of
'email' subsystem, ID: [email, outbound] complete
[2019-06-03 17:56:53] [info] 2019-06-03 17:56:53,951 INFO
[management.subsystems.ChildApplicationContextFacto ry] [main] Starting
'email' subsystem, ID: [email, inbound]
[2019-06-03 17:56:53] [info] 2019-06-03 17:56:53,989 INFO
[management.subsystems.ChildApplicationContextFacto ry] [main] Startup of
'email' subsystem, ID: [email, inbound] complete
[2019-06-03 17:56:53] [info] 2019-06-03 17:56:53,989 INFO
[management.subsystems.ChildApplicationContextFacto ry] [main] Starting
'Subscriptions' subsystem, ID: [Subscriptions, default]
[2019-06-03 17:56:54] [info] 2019-06-03 17:56:54,003 INFO
[management.subsystems.ChildApplicationContextFacto ry] [main] Startup of
'Subscriptions' subsystem, ID: [Subscriptions, default] complete
[2019-06-03 17:56:54] [info] 2019-06-03 17:56:54,670 INFO
[management.subsystems.ChildApplicationContextFacto ry] [main] Starting
'Synchronization' subsystem, ID: [Synchronization, default]
[2019-06-03 17:56:54] [info] 2019-06-03 17:56:54,732 INFO
[management.subsystems.ChildApplicationContextFacto ry] [main] Starting
'sysAdmin' subsystem, ID: [sysAdmin, default]
[2019-06-03 17:56:54] [info] 2019-06-03 17:56:54,747 INFO
[management.subsystems.ChildApplicationContextFacto ry] [main] Startup of
'sysAdmin' subsystem, ID: [sysAdmin, default] complete
[2019-06-03 17:56:55] [info] 2019-06-03 17:56:55,110 INFO
[management.subsystems.ChildApplicationContextFacto ry] [main] Startup of
'Synchronization' subsystem, ID: [Synchronization, default] complete
[2019-06-03 17:56:55] [info] 2019-06-03 17:56:55,162 INFO
[service.descriptor.DescriptorService] [main] Alfresco JVM -
v11.0.3+1-Debian-1; maximum heap size 3996,000MB
[2019-06-03 17:56:55] [info] 2019-06-03 17:56:55,162 INFO
[service.descriptor.DescriptorService] [main] Server Mode :PRODUCTION
[2019-06-03 17:56:55] [info] 2019-06-03 17:56:55,165 INFO
[service.descriptor.DescriptorService] [main] Alfresco Content Services
a démarré (Community). Version actuelle : 6.1.2 (r4fe1d0d0-b205) schéma
13 001. Version installée initialement : 6.1.2 (r4fe1d0d0-b205) schéma
13 001.
[2019-06-03 17:56:55] [info] 2019-06-03 17:56:55,176 INFO
[management.subsystems.ChildApplicationContextFacto ry] [main] Starting
'ActivitiesFeed' subsystem, ID: [ActivitiesFeed, default]
[2019-06-03 17:56:55] [info] 2019-06-03 17:56:55,385 INFO
[management.subsystems.ChildApplicationContextFacto ry] [main] Startup of
'ActivitiesFeed' subsystem, ID: [ActivitiesFeed, default] complete
[2019-06-03 17:56:55] [info] 2019-06-03 17:56:55,385 INFO
[management.subsystems.ChildApplicationContextFacto ry] [main] Starting
'Replication' subsystem, ID: [Replication, default]
[2019-06-03 17:56:55] [info] 2019-06-03 17:56:55,397 INFO
[management.subsystems.ChildApplicationContextFacto ry] [main] Startup of
'Replication' subsystem, ID: [Replication, default] complete
[2019-06-03 17:56:56] [info] 2019-06-03 17:56:56,967 INFO
[management.subsystems.ChildApplicationContextFacto ry] [main] Starting
'Messaging' subsystem, ID: [Messaging, default]

et j'ai bien les deux services suivants qui fonctionnent :

tomcat 12647 12.9 6.6 10113820 1085464 ? Ssl 17:55 2:20
/usr/lib/jvm/default-java/bin/java
-Djava.util.logging.config.file=/opt/alfresco/conf/logging.properties
-Djava.util.logging.manager=org.apache.juli.ClassLo aderLogManager
-Djava.awt.headless=true -XX:+UseG1GC -Djdk.tls.ephemeralDHKeySize=2048
-Djava.protocol.handler.pkgs=org.apache.catalina.we bresources
-Dorg.apache.catalina.security.SecurityListener.UMA SK=0027
-Dignore.endorsed.dirs= -classpath
/usr/share/tomcat9/bin/bootstrap.jar:/usr/share/tomcat9/bin/tomcat-juli.jar
-Dcatalina.base=/opt/alfresco -Dcatalina.home=/usr/share/tomcat9
-Djava.io.tmpdir=/tmp org.apache.catalina.startup.Bootstrap start
tomcat 13600 0.0 0.4 671712 73920 ? Sl 17:56 0:00
/usr/lib/libreoffice/program/soffice.bin
-accept=socket,host=127.0.0.1,port=2022;urp;
-env:UserInstallation=file:///tmp/.jodconverter_socket_host-127.0.0.1_port-2022
-headless -nocrashreport -nodefault -nofirststartwizard -nolockcheck
-nologo -norestore

Mais rien n'y fait, il est toujours impossible de se connecter.
Pourtant, nmap indique bien que les ports 8080 et 8009 sont à l'écoute :
8009/tcp open ajp13
8080/tcp open http-proxy

J'avoue que je ne sais plus où chercher...

Bien cordialement,

JKB
BERTRAND Joël (04/06/2019, 14h10)
Trouvé.

Il faut rajouter messaging.subsystem.autoStart=false
dans le fichier de conf.

J'ai trouvé cette information après avoir lu de nombreuses heures les
forums d'Alfresco.

JKB
Discussions similaires
debian testing + debian lenny + xen + grub 2 / 1

Installer un logiciel debian testing sur une debian stable

debian testing mdp root

JRE et Debian Testing


Fuseau horaire GMT +2. Il est actuellement 04h15. | Privacy Policy