cerhu > linux.debian.user.french

roger.tarani (01/08/2019, 21h40)
----- Original Message -----
> From: "Pascal Hambourg" <pascal>
> To: debian-user-french
> Sent: Thursday, August 1, 2019 8:23:11 PM
> Subject: Re: Buster problème réseau étonnant
> Le 01/08/2019 à 15:13, roger.tarani a écrit :
> Ce n'est pas le ping qui ne passe pas, c'est la résolution DNS qui
> foire. Cela peut être juste une défaillance du DNS ou une pertede
> connectivité IP totale. Pour différencier les deux, il faut cibler
> directement une adresse IP connue pour répondre au ping.

J'ai fait une série de ping sur une machine du LAN et sur une machine distante que je connais :
ça ping. Mais il faut attendre pour que ça le problème réapparaisse.

Je précise que la config réseau est celle de l'installation de Buster.
depuis l'applet NetworkManager, j'ai juste fixé IPv4 / IPv4 Method : Manual
Address ...
Netmask ...
Gateway ...

DNS et Routes est sur automatic.
Rien de plus.

Je n'ai pas d'outil de monitoring permanent, j'utilise juste les commandes habituelles (ping, route traceroute, ip a...)

Quand je lis le manuel Debian, les "legacy methods/anciennes méthodes " sont mieux repérées mais je n'ai pas trouvé
[..]
[..]
-> il n'y a aucune date ni référence, on parle de iptables et nonde nftables qui est son successeur recommandé. On parle encore de resolvconf, etc.
ça me laisse perplexe.
C'est quoi ton manuel Debian de référence ?
Merci.
Erwann Le Bras (02/08/2019, 11h10)
bonjour

Le 01/08/2019 à 21:33, roger.tarani a écrit :
> J'ai fait une série de ping sur une machine du LAN et sur une machine
> distante que je connais :
> ça ping. Mais il faut attendre pour que ça le problème réapparaisse.
> Je précise que la config réseau est celle de l'installation de Buster.
> depuis l'applet NetworkManager, j'ai juste fixé IPv4 / IPv4 Method : Manual
> Address ...
> Netmask ...
> Gateway ...
> DNS et Routes est sur automatic.
> Rien de plus.


DNS sur "automatique" alors que l'adresse IP est fixée manuellement?

comment la machine connait-elle le DNS à utiliser?

je pense que le problème vient de là : il faut fixer le DNS à utiliser :
la passerelle (si elle en a un), celui du FAI ou OpenDNS (208.67.222.220
et 208.67.220.222)

cordialement
roger.tarani (02/08/2019, 17h30)
----- Original Message -----
[..]
> je pense que le problème vient de là : il faut fixer le DNS à
> utiliser :
> la passerelle (si elle en a un), celui du FAI ou OpenDNS
> (208.67.222.220
> et 208.67.220.222)
> cordialement


Bon !
J'ai juste ajouté 208.67.222.220, 208.67.222.222 à DNS (avec l'IPde la gateway, ça fonctionne aussi).
L'accès à internet est opérationnel et a l'air de tenir.
J'ai laissé Routes en "automatic": Ok ?...

J'ai aussi fait, pour voir :
$ sudo systemctl restart networking.service
et
$ sudo systemctl restart NetworkManager
Ça n'affecte pas l'accès à internet mais la commande pour NMmodifie l'icône de l'applet de NM (ça devient une petite croixblanche sur un réseau grisé).

Est-ce que je peux vraiment (sur un portable ou une machine de bureau) arriver à configurer nm-applet pour gérer aisément les réseaux au choix depuis l'applet ou en CLI ?

Merci

Discussions similaires
buster : petit problème avec LibreOffice writer [résolu]

ipw2200 problème etonnant

Problème d'impression en réseau (réseau invisible dans explorateur réseau)

v-buster


Fuseau horaire GMT +2. Il est actuellement 03h37. | Privacy Policy