cerhu > linux.debian.user.french

hamster (05/08/2019, 01h10)
Salut.

Ca fesait plusieurs mois que j'avais remarqué que mon ordi n'était plus
aussi rapide que d'habitude. Mais la brusquement il s'est mis a etre d'une
lenteur maladive. Du genre a mettre quelques secondes a afficher une
lettre tapée dans un terminal. Alors regarder des vidéos sur youtube j'en
parle meme pas… Un peu comme un système qui swappe a mort, sauf que le
voyant de fonctionnement du disque dur reste éteint et htop me dit que mon
processeur se tourne les pouces.

J'ai redémarré sur un système live sur clef USB : meme lenteur maladive.

J'ai voulu aller regarder dans le BIOS : lui aussi est terriblement lent.

J'ai restauré les paramètres par défauts du BIOS, ca a permis de retrouver
une vitesse normale dans le BIOS et sur système live, mais quand j'ai
relancé debian ca a fonctionné normalement pendant quelques minutes puis
s'est remis a ramer sans raison.

J'ai fait un test de mémoire : tout est OK.

J'en perds mon latin, si quelqu'un a une idée lumineuse je suis preneur.

Merci d'avance.
Basile Starynkevitch (05/08/2019, 06h40)
On 8/5/19 1:02 AM, hamster wrote:
> Salut.
> Ca fesait plusieurs mois que j'avais remarqué que mon ordi n'était plus
> aussi rapide que d'habitude. Mais la brusquement il s'est mis a etre d'une
> lenteur maladive. Du genre a mettre quelques secondes a afficher une
> lettre tapée dans un terminal. Alors regarder des vidéos sur youtube j'en
> parle meme pas? Un peu comme un système qui swappe a mort, sauf que le
> voyant de fonctionnement du disque dur reste éteint et htop me dit que mon
> processeur se tourne les pouces.


Il faut commencer par éliminer les problèmes logiciels. Lancer la
commande top dans un terminal sous root (donc en sudo), et observer tout
processus trop gourmand. C'est déjà fait avec htop

Observer aussi l'activité système avec xosview

Ensuite, lancer la commande dmesg sous root, et y lire les messages de
log. Peut-être des messages anormaux?

Enfin, le disque peut être physiquement abimé donc mourant. Installer le
paquet smartmontools puis utiliser avec précaution (donc bien lire la
doc avant) l'utilitaire smartctl. Il permettrait de diagnostiquer
l'agonie du disque dur (mais pas de le réparer; il faudrait peut-être le
changer).

Librement
Scala Francois (05/08/2019, 08h10)
Salut,

Je pense que c'est un problème de poussière, qui empêche un bon
refroidissement du processeur. Du coup, pour éviter la surchauffe, il
limite la vitesse d'horloge puis les attente pour que la température
redescende un peu.

Cordialement.

François.

On 05/08/2019 01:02, hamster wrote:
[..]
Gaëtan Perrier (05/08/2019, 12h50)
Si le bios est lent également je pense que l'on peut exclure un problème purement debian.
Mais a tout hasard si ton système est partionné regarde si /varne serait pas plein. J'ai déjà eu le cas d'un log en boucle qui a saturé la partition et ça rendait le système très lent.

Le 5 août 2019 07:46:06 GMT+02:00, Scala Francois <francois> a écrit :
[..]
hamster (05/08/2019, 20h00)
Le 05/08/2019 à 07:46, Scala Francois a écrit :
> Salut,
> Je pense que c'est un problème de poussière, qui empêche un bon
> refroidissement du processeur. Du coup, pour éviter la surchauffe, il
> limite la vitesse d'horloge puis les attente pour que la température
> redescende un peu.


J'ai démonté, nettoyé, changé la pate thermique qui était toute dure et
craquelée.

J'ai aussi installé lm-sensors et un truc pour voir la fréquence du
processeur.

De temps en temps, le processeur se bloque a 800 MHz, c'est dans ces
moments la qu'il est particulièrement lent. Pourtant toutes les
températures sont en dessous de 60 °C.

Je n'ai pas de partition /var séparée et ma partition / n'est pas pleine.
ajh-valmer (05/08/2019, 21h50)
On Monday 05 August 2019 19:59:14 hamster wrote:
> Le 05/08/2019 à 07:46, Scala Francois a écrit :
> Je n'ai pas de partition /var séparée et ma partition / n'est pas pleine.


Tu as bien le répertoire /var et non plein ?

As tu bien le répertoire /tmp avec ces droits ? :
drwxrwxrwt

Que dit la commande "df -h" ?
Basile Starynkevitch (05/08/2019, 21h50)
On 8/5/19 9:45 PM, ajh-valmer wrote:
> On Monday 05 August 2019 19:59:14 hamster wrote:
>> Le 05/08/2019 à 07:46, Scala Francois a écrit :
>> Je n'ai pas de partition /var séparée et ma partition / n'est pas pleine.

> Tu as bien le répertoire /var et non plein ?
> As tu bien le répertoire /tmp avec ces droits ? :
> drwxrwxrwt
> Que dit la commande "df -h" ?


Et aussi "df -hi" ?
hamster (05/08/2019, 22h50)
Le 05/08/2019 à 21:45, ajh-valmer a écrit :
> On Monday 05 August 2019 19:59:14 hamster wrote:
>> Le 05/08/2019 à 07:46, Scala Francois a écrit :
>> Je n'ai pas de partition /var séparée et ma partition / n'est pas pleine.

> Tu as bien le répertoire /var et non plein ?
> As tu bien le répertoire /tmp avec ces droits ? :
> drwxrwxrwt


# ls -l /
total 100
drwxr-xr-x   2 root root  4096 avril  9 07:00 bin
drwxr-xr-x   3 root root  4096 juil. 21 09:36 boot
drwxr-xr-x  19 root root  3460 août   5 21:08 dev
drwxr-xr-x 164 root root 12288 août   5 18:02 etc
drwxr-xr-x   6 root root  4096 oct.  15  2018 home
lrwxrwxrwx   1 root root    29 juin  25 17:26 initrd.img ->
boot/initrd.img-4.9.0-9-amd64
drwxr-xr-x  19 root root  4096 mars  27 00:08 lib
drwxr-xr-x   2 root root  4096 mars  27 00:08 lib64
drwx------   2 root root  4096 mars   3  2017 lost+found
drwxr-xr-x   4 root root  4096 mars  13  2017 media
drwxr-xr-x   5 root root  4096 févr.  7  2018 mnt
drwxr-xr-x   3 root root  4096 sept.  2  2018 opt
dr-xr-xr-x 196 root root     0 août   5 18:01 proc
drwx------  13 root root  4096 juil. 25 02:52 root
drwxr-xr-x  34 root root  1060 août   5 18:20 run
drwxr-xr-x   2 root root 12288 juin   1 16:26 sbin
drwxr-xr-x   2 root root  4096 mars   3  2017 srv
dr-xr-xr-x  13 root root     0 août   5 18:01 sys
drwxrwxrwt  13 root root 16384 août   5 22:39 tmp
drwxr-xr-x  10 root root  4096 juil.  5  2018 usr
drwxr-xr-x  12 root root  4096 mai   31  2017 var
lrwxrwxrwx   1 root root    26 juin  25 17:26 vmlinuz ->
boot/vmlinuz-4.9.0-9-amd64

> Que dit la commande "df -h" ?
> Et aussi "df -hi" ?


# df -h
Sys. de fichiers Type     Taille Utilisé Dispo Uti% Monté sur
udev             devtmpfs   1,9G       0  1,9G   0% /dev
tmpfs            tmpfs      390M    6,3M  383M   2% /run
/dev/sda3        ext4        15G     12G  2,4G  83% /
tmpfs            tmpfs      2,0G     34M  1,9G   2% /dev/shm
tmpfs            tmpfs      5,0M    4,0K  5,0M   1% /run/lock
tmpfs            tmpfs      2,0G       0  2,0G   0% /sys/fs/cgroup
/dev/sda4        ext4       622G    572G   50G  93% /home
tmpfs            tmpfs      390M     48K  390M   1% /run/user/1000

# df -hi
Sys. de fichiers Type     In?uds IUtil. ILibre IUti% Monté sur
udev             devtmpfs   484K    475   483K    1% /dev
tmpfs            tmpfs      487K    753   486K    1% /run
/dev/sda3        ext4       939K   390K   549K   42% /
tmpfs            tmpfs      487K     64   487K    1% /dev/shm
tmpfs            tmpfs      487K      5   487K    1% /run/lock
tmpfs            tmpfs      487K     15   487K    1% /sys/fs/cgroup
/dev/sda4        ext4        40M   364K    40M    1% /home
tmpfs            tmpfs      487K     33   487K    1% /run/user/1000
ajh-valmer (05/08/2019, 23h10)
On Monday 05 August 2019 22:44:17 hamster wrote:
> drwxrwxrwt  13 root root 16384 août   5 22:39 tmp
> # df -h
> Sys. de fichiers Type     Taille Utilisé Dispo Uti% Monté sur
> /dev/sda3        ext4        15G     12G  2,4G  83% /
> /dev/sda4        ext4       622G    572G   50G  93% /home


Tout semble normal.

Quel est le volume de /var/ ?

Quelles partitions sont sur sda1 et sda2 ?

As tu relancé grub ?
update-grub2 & grub-install /dev/sda

Inspecter aussi les processus :
# ps aux
(voir ceux qui pourraient ralentir...)

Bonne nuit.
hamster (05/08/2019, 23h30)
Le 05/08/2019 à 23:04, ajh-valmer a écrit :
> Quel est le volume de /var/ ?


# du -ah --max-depth=1 /var
20K    /var/www
665M    /var/cache
0    /var/run
626M    /var/lib
0    /var/lock
4,0K    /var/opt
27M    /var/log
21M    /var/tmp
9,0M    /var/backups
444K    /var/mail
4,0K    /var/local
2,2M    /var/spool
1,4G    /var

> Quelles partitions sont sur sda1 et sda2 ?


windows sur sda1 et swap sur sda2

> As tu relancé grub ?
> update-grub2 & grub-install /dev/sda


non, je vais le faire, mais en fait plus probablement passer a buster

> Inspecter aussi les processus :
> # ps aux
> (voir ceux qui pourraient ralentir...)


actuellement y'a pas grand chose, faut que j'attende un moment ou il
rame et que je refasse ps aux
Daniel Caillibaud (07/08/2019, 13h20)
Le 05/08/19 =C3=A0 19:59, hamster <hamster> a =C3=A9crit :
> De temps en temps, le processeur se bloque a 800 MHz, c'est dans ces
> moments la qu'il est particuli=C3=A8rement lent. Pourtant toutes les
> temp=C3=A9ratures sont en dessous de 60 =C2=B0C.


Alors tu as peut-=C3=AAtre qqchose qui fait passer ton processeur en mode =
=C3=A9conome en =C3=A9nergie,
regarde dans les r=C3=A9glages d'=C3=A9nergie.

Ou alors c'est un r=C3=A9glage bios ou OS qui le fait passer dans ce mode q=
uand la batterie est
faible=E2=80=A6

--=20
Daniel

L'homme est imparfait, mais ce n'est pas =C3=A9tonnant si l'on songe =C3=A0=
=20
l'=C3=A9poque o=C3=B9 il fut cr=C3=A9=C3=A9.
Alphonse Allais
hamster (09/08/2019, 02h10)
Le 07/08/2019 à 13:16, Daniel Caillibaud a écrit :
> Le 05/08/19 à 19:59, hamster <hamster> a écrit :
> Alors tu as peut-être qqchose qui fait passer ton processeur en mode économe en énergie,
> regarde dans les réglages d'énergie.
> Ou alors c'est un réglage bios ou OS qui le fait passer dans ce mode quand la batterie est
> faible?


J'ai flashé le BIOS et après quelques redémarrages l'horloge s'est
décalée d'une heure et les problèmes de lenteur ont disparu. Reste a
voir si ca tiendra dans la durée.
Pierre L. (09/08/2019, 10h00)
Ca reste toute de même étonnant que ca arrive d'un coup !

Aux experts, existe-il une certaine possibilité à un OS de
régler/discuter avec le bios ? Sans me documenter sur le sujet, il m'a
toujours pourtant semblé que le bios est un endroit assez hermétique...

Le 09/08/2019 à 02:09, hamster a écrit :
Pascal Hambourg (09/08/2019, 20h30)
Le 09/08/2019 à 09:52, Pierre L. a écrit :
> existe-il une certaine possibilité à un OS de
> régler/discuter avec le bios ?


Bien sûr. Notamment via l'ACPI.
Yves Rutschle (13/08/2019, 09h40)
On Fri, Aug 09, 2019 at 09:52:31AM +0200, Pierre L. wrote:
> Ca reste toute de même étonnant que ca arrive d'un coup !


Ça peut être la pile du BIOS qui commence à flancher, le
BIOS qui a perdu sa configuration, et qui par exemple décide
de faire tourner les RAM plus lentement qu'elles ne le
peuvent. Ou pire, sans cache.
(Je sais pas si ce genre de chose existe toujours, mais
ça se pouvait "y'a longtemps").

Y.
Discussions similaires
Ils inventent: L'anxiété maladive dès cinq ans.

Hypocrisie maladive (ouaze Re : Quel moyen pour tenir un voisin agressif à distance ?)

lenteur de word entraine lenteur ordinateur

Castration chimique pour éviter masturbation maladive ?


Fuseau horaire GMT +2. Il est actuellement 12h19. | Privacy Policy