cerhu > linux.debian.user.french

MERLIN Philippe (21/03/2020, 15h10)
Bonjour,
Je suis l'heureux utilisateur d'un Pc portable Lenovo W520, ce portable
possède deux cartes Vidéos et son.
Cartes Vidéo Intel et Nvidia GF108GLM
Carte Son Intel 6 Series/C200 et Nvidia GF108
Ne faisant pas de jeux je n'utilise pas la carte Nvidia la carte Intel me suffit
amplement.
Même choix pour le son.
Mon problème est le suivant des fois j'ai le son qui tombe en marche dès
l'ouverture de ma session (évènement très rare) la plupart du temps pour avoir
du son je dois faire semblant de modifier les réglages de la carte sonpar
alsamixer ou son équivalent.
En comparant les dmesg dans les deux cas la carte intel est bien initialisée
et configurée , quand on a du son la carte son nvidia semble être ignorée,
dans le cas contraire on a plein d'erreurs d'initialisation avec une sortie
HDMI qui n'existe pas sur cet ordinateur.
Mon problème est le suivant je veux envoyer un rapport de Bug mais je ne sais
pas sélectionner le "coupable", Alsa, Kernel, Systemd ou .....
Si vous avez eu la patience de lire ce message et que vous avez une suggestion
je suis preneur.
Philippe Merlin
Bernard Schoenacker (21/03/2020, 15h20)
----- Mail original -----
[..]
> sortie
> HDMI qui n'existe pas sur cet ordinateur.
> Mon problème est le suivant je veux envoyer un rapport de Bug mais je
> ne sais
> pas sélectionner le "coupable", Alsa, Kernel, Systemd ou .....
> Si vous avez eu la patience de lire ce message et que vous avez une
> suggestion
> je suis preneur.
> Philippe Merlin


bonjour,

pourquoi ne pas créer un fichier dot asoundrc ?

voici une base :
cat .asoundrc

# create by vokoscreen 2.4.8 Beta

pcm.pulse {
type pulse
}

ctl.pulse {
type pulse
}

pcm.!default {
type asym
playback.pcm {
type plug
slave.pcm "hw:0,1"
}
capture.pcm {
type plug
slave.pcm "hw:2,0"
}
}

à toi de corriger les adresses

merci pour ton aimable attention

bien à toi
bernard
MERLIN Philippe (21/03/2020, 17h20)
Le samedi 21 mars 2020, 14:10:53 CET Bernard Schoenacker a écrit :
> ----- Mail original -----
> bonjour,
> pourquoi ne pas créer un fichier dot asoundrc ?
> voici une base :
> cat .asoundrc

Merci de ta suggestion, mais je ne vois pas comment résoudre le problème en
paramétrant .asoundrc.
mon problème est le suivant :
aplay -l
aplay -l
cat /proc/asound/cards

cat /proc/asound/modules
[ 5.065098] snd_hda_codec_hdmi hdaudioC1D0: HDMI: invalid ELD buf size -1

Il me semble que c'est normal n'ayant pas de sortie HDMI sur cet ordi
[..]
Olivier Humbert (21/03/2020, 17h30)
Bonjour.

Si le problème c'est l'activation du HDMI, tu peux probablement tenter
de blacklister le module "snd_hda_codec_hdmi".

Concernant ta demande initiale, j'aurai tendance faire ce bogue contre
le noyau puisque les pilotes audio, même si provenant du projet alsa,
sont intégrés dans le noyau. Ne t'inquiète pas trop, si les mainteneurs
pensent que le bogue est mal attribué, ils le redirigeront vers le bon
paquet.

Bonne contribution à toi.
Olivier
Discussions similaires
ecrire à la mairie de Breda dans les Pays bas, comment écrire l'adresse

Pré-rapport et rapport d'expertise, pièces, ...

langue opérationnelle pour ecrire un rapport

ecrire un cgi-bin en sh


Fuseau horaire GMT +2. Il est actuellement 12h59. | Privacy Policy