cerhu > comp.* > comp.usenet.lecteurs-de-news

siger (02/06/2020, 20h04)
bonjour,

Avec MesNews, j'essaye de plonker quelqu'un mais ?a ne marcha pas.

l'exp?diteur est : "Medor hamery (je mors)" <médor> (avec les
guillemets)

Et quand je le plonke, le champ nom est celui-ci :

=?UTF-8?B?Ik1lZG9yIGhhbWVyeSAoamUgbW9ycykiIDxtw4PCqWRvck Bhb2wuY29tPg==?=

et rien dans le champ de l'adresse m?l.

Si je valide ?a, ?a ne marche pas.

Si je remplace par "Medor hamery (je mors)" ou par "Medor hamery (je
mors)" <médor>, ?a ne marche pas non plus.

Utilise t-il un syst?me anti-plonkage, ou est-ce une simple
incompatibilit? d'?criture (comme les informaticiens adorent faire) ?
les renardeaux (02/06/2020, 20h23)
Bonjour,

Le message du mardi 02/06/2020 (cf. <rb64c6$7p8$1> ),
siger dixit, stipule notammant :

> bonjour,


> Avec MesNews, j'essaye de plonker quelqu'un mais ?a ne marcha pas.


> l'exp?diteur est : "Medor hamery (je mors)" <médor> (avec
> les guillemets)


> Et quand je le plonke, le champ nom est celui-ci :


> =?UTF-8?B?Ik1lZG9yIGhhbWVyeSAoamUgbW9ycykiIDxtw4PCqWRvck Bhb2wuY29tPg==?=


> et rien dans le champ de l'adresse m?l.


> Si je valide ?a, ?a ne marche pas.


> Si je remplace par "Medor hamery (je mors)" ou par "Medor hamery (je
> mors)" <médor>, ?a ne marche pas non plus.


> Utilise t-il un syst?me anti-plonkage, ou est-ce une simple
> incompatibilit? d'?criture (comme les informaticiens adorent faire) ?


Je n'ai pas de message de lui mais j'ai pu configurer ? la mimne une
r?gle sans soucis.
Stéphane CARPENTIER (02/06/2020, 22h04)
Le 02-06-2020, siger <s> a écrit :
> l'expéditeur est : "Medor hamery (je mors)" <médor> (avec les
> guillemets)


T'as un problème d'affichage de son accent, ça doit venir de là. Il a
une adresse avec de l'utf-8 et tu essayes de l'afficher avec de latin1
ou un truc dans le genre.

>=?UTF-8?B?Ik1lZG9yIGhhbWVyeSAoamUgbW9ycykiIDxtw4PCqWRvck Bhb2wuY29tPg==?=


C'est bizarre comme affichage.

> Utilise t-il un système anti-plonkage,


Ça n'existe pas ça. La seule façon d'éviter le plonkage est de changer
ses en-têtes constamment.

> ou est-ce une simple
> incompatibilité d'écriture (comme les informaticiens adorent faire) ?


Il faut passer à l'utf-8, c'est bien. Le latin1/windowscpchaipacombien/iso
c'est périmé et c'est source de problème pour les échanges avec les autres.
siger (02/06/2020, 22h50)
Stéphane CARPENTIER a formulé ce mardi :

> Il faut passer à l'utf-8, c'est bien. Le latin1/windowscpchaipacombien/iso
> c'est périmé et c'est source de problème pour les échanges avec les autres.


Dans les paramètres il y a :
iso-8859-15
iso-8859-1
utf-8

c'est la config par défaut.

Je ne garde que UTF-8 ?
Stéphane CARPENTIER (03/06/2020, 00h16)
Le 02-06-2020, siger <s> a écrit :
> Stéphane CARPENTIER a formulé ce mardi :
>> Il faut passer à l'utf-8, c'est bien. Le
>> latin1/windowscpchaipacombien/iso c'est périmé et c'est source de
>> problème pour les échanges avec les autres.

> Dans les paramètres il y a : iso-8859-15 iso-8859-1


La différence entre ces ceux encodages, c'est que le -15 à le caractère
euro ? alors que le -1 est plus ancien et ne l'a pas (si je me souviens
bien).

En gros, avec ces deux encodages, ça va bien se passer pour écrire en
français. Mais si tu veux mettre des courtes citations dans d'autres
langues (par exemple je dirais sans certitude le ß allemand), mais il va
être facile de trouver des caractères accentués nordiques (ØÐþ), voir du
russe (???), du japonais (???), de l'arabe (???), de l'hébreux (???)
ou ce que tu veux, que tu ne pourras pas afficher avec l'un de ces deux
encodages.

Soit tu jongles entre les encodages au sein du même message, ce qui est
lourd. Soit, le mieux, est de passer à l'utf-8 pour tout afficher et
oublier les deux autres qui deviennent, de fait, inutiles. Ça, c'est
pour ce que tu écris, pour ce que tu lis, ça dépend de l'encodage
utilisé par les autres.

> utf-8
> c'est la config par défaut.
> Je ne garde que UTF-8 ?


Je ne connais pas mesnews. Tu peux essayer deux choses. D'abord enlever les
deux lignes iso pour voir si ça marche. Si ça pose d'autres problèmes,
tu peux mettre utf-8 au dessus des autres pour espérer qu'il soit choisi en
priorité.
Olivier Miakinen (03/06/2020, 07h23)
Le 02/06/2020 22:04, St?phane CARPENTIER r?pondait ? siger :
>> l'exp?diteur est : "Medor hamery (je mors)" <médor> (avec les
>> guillemets)

> T'as un probl?me d'affichage de son accent, ?a doit venir de l?. Il a
> une adresse avec de l'utf-8 et tu essayes de l'afficher avec de latin1
> ou un truc dans le genre.


Non, siger n'a aucun probl?me d'affichage, c'est Medor hamery qui a un probl?me
d'encodage (? moins qu'il ne le fasse expr?s). En tout cas, la cha?ne indiqu?e
se d?code bien telle que siger l'?crit.

>>=?UTF-8?B?Ik1lZG9yIGhhbWVyeSAoamUgbW9ycykiIDxtw4PCqWRvck Bhb2wuY29tPg==?=

> C'est bizarre comme affichage.


Ce n'est pas bizarre, c'est l'encodage en Base64 d'un texte en UTF-8, selon
le RFC 2047, pour mettre dans un ent?te cens? ne contenir que de l'ASCII
un texte qui contient autre chose que de l'ASCII.

Si on d?code juste le Base64, les octets obtenus correspondant au ? é ?
sont ? c3 83 c2 a9 ?, c'est-?-dire un ? ? ? (c3 a8) suivi d'un ? ? ? (c2 a9).

Cela confirme donc que le d?codage fait par le MesNews de siger est correct,
et que c'est l'encodage fait par Medor qui ne l'est pas.

***

Maintenant, pour r?pondre ? la question, je ne sais pas. Je ne connais pas
MesNews, aussi je ne sais pas s'il faut filtrer sur le texte encod? ou sur
le texte d?cod?.
siger (03/06/2020, 10h24)
Olivier Miakinen a utilis? son clavier pour ?crire :
[..]
> sont ? c3 83 c2 a9 ?, c'est-?-dire un ? ? ? (c3 a8) suivi d'un ? ? ? (c2 a9).
> Cela confirme donc que le d?codage fait par le MesNews de siger est correct,
> et que c'est l'encodage fait par Medor qui ne l'est pas.
> ***
> Maintenant, pour r?pondre ? la question, je ne sais pas. Je ne connais pas
> MesNews, aussi je ne sais pas s'il faut filtrer sur le texte encod? ou sur
> le texte d?cod?.


J'ai fait divers essais, un param?trage a march? :

NOM CONTIENT "Medor hamery (je mors)" <médor>

et d?valid? les autres crit?res.

En copiant le nom sur l'affichag de MesNews, il y a une espace ? la
fin. Il est possible que le crit?re par d?faut IDENTIQUE ? ne marche
pas avec cet espace que je n'avais pas vu.
Elephant Man (03/06/2020, 10h27)
Le 03/06/2020 à 10:24, siger a écrit :

> J'ai fait divers essais, un paramétrage a marché :
> NOM CONTIENT "Medor hamery (je mors)" <médor>
> et dévalidé les autres critères.


Sachant qu'il aura changé de pseudo dans quelques heures, on va dire que
ça enrichit la recherche théorique :)
Olivier Miakinen (03/06/2020, 10h31)
Le 03/06/2020 à 10:27, Elephant Man à siger :
>> NOM CONTIENT "Medor hamery (je mors)" <médor>

> Sachant qu'il aura changé de pseudo dans quelques heures, on va dire que
> ça enrichit la recherche théorique :)


Mettre comme filtre :
NOM CONTIENT hamery
a des chances de suivre quelques changements de pseudo, non ?
Elephant Man (03/06/2020, 10h33)
Le 03/06/2020 à 10:31, Olivier Miakinen a écrit :

>>> NOM CONTIENT "Medor hamery (je mors)" <médor>


>> Sachant qu'il aura changé de pseudo dans quelques heures, on va dire que
>> ça enrichit la recherche théorique :)


> Mettre comme filtre :
> NOM CONTIENT hamery
> a des chances de suivre quelques changements de pseudo, non ?


Ce serait valable s'il y avait une logique, mais il n'y en a aucune, et
pour cause. Bon, le bon côté c'est qu'il y a une chance de bloquer le
vrai Eric H, ce sera toujours ça.
Olivier Miakinen (03/06/2020, 11h03)
Le 03/06/2020 10:33, Elephant Man a écrit :
>> Mettre comme filtre :
>> NOM CONTIENT hamery
>> a des chances de suivre quelques changements de pseudo, non ?

> Ce serait valable s'il y avait une logique, mais il n'y en a aucune, et
> pour cause. Bon, le bon côté c'est qu'il y a une chance de bloquer le
> vrai Eric H, ce sera toujours ça.


Ah, parce que ce n'est pas le vrai ? ;-)

En fait c'est logique, parce que dans mes propres filtres je n'ai pas
mis « hamery » mais « @meta-science.fr ».
siger (03/06/2020, 12h26)
Olivier Miakinen a utilisé son clavier pour écrire :
> Le 03/06/2020 10:33, Elephant Man a écrit :
> Ah, parce que ce n'est pas le vrai ? ;-)
> En fait c'est logique, parce que dans mes propres filtres je n'ai pas
> mis « hamery » mais « @meta-science.fr ».


Non, il fait partie de ceux qui lui répondent abondamment, uniquement
pour se foutre de lui.
Stéphane CARPENTIER (03/06/2020, 18h33)
Le 03-06-2020, Olivier Miakinen <om+news> a écrit :
> Le 02/06/2020 22:04, Stéphane CARPENTIER répondait à siger :
> Non, siger n'a aucun problème d'affichage, c'est Medor hamery qui a un
> problème d'encodage (à moins qu'il ne le fasse exprès). En tout cas,
> la chaîne indiquée se décode bien telle que siger l'écrit.
>> Ce n'est pas bizarre, c'est l'encodage en Base64 d'un texte en UTF-8,

> selon


Oui, fatigué, j'ai même pas reconnu l'encodage en Base64.

> Cela confirme donc que le décodage fait par le MesNews de siger est
> correct, et que c'est l'encodage fait par Medor qui ne l'est pas.


Oui, mais si le décodage des caractères est toujours le même, ça devrait
comparer deux caractères mal décodés de la même façon et ça devrait
marcher. C'est pour ça que ça ressemble à un caractère qui est décodé
d'une façon lors de l'affichage et d'une autre façon lors de
l'enregistrement de la valeur.
Olivier Miakinen (03/06/2020, 19h05)
Le 03/06/2020 18:33, St?phane CARPENTIER m'a r?pondu :
>> Cela confirme donc que le d?codage fait par le MesNews de siger est
>> correct, et que c'est l'encodage fait par Medor qui ne l'est pas.

> Oui, mais si le d?codage des caract?res est toujours le m?me, ?a devrait
> comparer deux caract?res mal d?cod?s de la m?me fa?on et ?a devrait
> marcher.


.... ce ? quoi siger a r?pondu que dans son premier filtre il y avait une
espace en trop ? la fin. C'est cette espace qui a emp?ch? la comparaison
de fonctionner, et non les caract?res ? et ?. D'ailleurs un nouvel essai,
sans cette espace mais avec tous les autres caract?res, a fonctionn?.
Stéphane CARPENTIER (03/06/2020, 20h10)
Le 03-06-2020, Olivier Miakinen <om+news> a écrit :
> Le 03/06/2020 18:33, Stéphane CARPENTIER m'a répondu :
> ... ce à quoi siger a répondu que dans son premier filtre il y avait une
> espace en trop à la fin. C'est cette espace qui a empêché la comparaison
> de fonctionner, et non les caractères à et ©. D'ailleurs un nouvel essai,
> sans cette espace mais avec tous les autres caractères, a fonctionné.


Oui, j'ai vu sa réponse ensuite. Les espaces (incluant les tabulations et
tout ça), c'est fourbe. Mais quand il y a clairement un gros problème
d'encodage affiché, ça détourne l'analyse.

Discussions similaires
Plonkage

[TRES URGENT] Plonkage

anti virus/ anti-trojans,anti-vers,anti-salers, anti-spyware -fire

ppc pré-plonkage..


Fuseau horaire GMT +2. Il est actuellement 03h08. | Privacy Policy