cerhu > comp.os.* > comp.os.linux.configuration

Vincent GAUVIN (18/04/2005, 09h08)
Bonjour
J'avais l'habitude d'utiliser kudzu sur des redhat. Je n'ai jamais eu
aucun pb.
Je viens d'installer une vector linux 4. (je crois que c'est à base de
slackware)
Si j'enlève ma carte réseau(3com) pour en remttre une autre (realtek),
kudzu détecte bien que la 3com est remove mais il ne me propose pas
d'installer la realtek. Pourtant il l'a bien trouvée, l'entrée
correspondante est dans /etc/sysconfig/hwconf.
une idée?
c'est un package kudzu-0.99.99-1.i386
merci
Rakotomandimby (R12y) Mihamina (18/04/2005, 10h29)
( Mon, 18 Apr 2005 09:08:00 +0200 ) Vincent GAUVIN :

> Bonjour


bonjour

> une idée?


juste une idée.

- enlève tout,
- lance kudzu,
- remets la nouvelle
- lance kudzu.

ça donne quoi?
Vincent GAUVIN (18/04/2005, 10h45)
Rakotomandimby (R12y) Mihamina a écrit :
> ( Mon, 18 Apr 2005 09:08:00 +0200 ) Vincent GAUVIN :
> bonjour
> juste une idée.
> - enlève tout,
> - lance kudzu,
> - remets la nouvelle
> - lance kudzu.
> ça donne quoi?


Merci de ton aide.
Rien;-( j'avais déjà essayé:-)
-j'enlève tout, je lance kudzu : il me dit remove machin chose et tout bien.
-je remets la nouvelle je lance kudzu : il me dit rien mais il modifie
quand même le hwconf avec la bonne entrée pour la nouvelle carte mais il
charge pas le bon module.

En fait depuis tout à l'heure j'ai un peu avancé:-)
Apparemment le pb est que kudzu détecte bien ma carte mais le système ne
charge pas le module correspondant automatiquement. Kudzu faisait ça
très bien sur les rh que j'ai utilisées (7.2 et 9). C'est lui qui
modifiait le modprobe.conf avec le bon module après avoir détecté la
carte. (sous réserve de cartes pas trop /exotiques/ evidemment)

mais là il ne le fait plus ;-(
Rakotomandimby (R12y) Mihamina (18/04/2005, 10h58)
( Mon, 18 Apr 2005 10:45:52 +0200 ) Vincent GAUVIN :
> mais là il ne le fait plus ;-(


Bon cela dit, entre nous, on a pas besoin de kudzu pour detecter une realtek
hein... :-)

tu fais un lspci, et tu charge à la main le module qu'il faut... :-)
Vincent GAUVIN (18/04/2005, 11h28)
Rakotomandimby (R12y) Mihamina a écrit :
> ( Mon, 18 Apr 2005 10:45:52 +0200 ) Vincent GAUVIN :
>>mais là il ne le fait plus ;-(
>> Bon cela dit, entre nous, on a pas besoin de kudzu pour detecter une realtek

> hein... :-)
> tu fais un lspci, et tu charge à la main le module qu'il faut... :-)


Ben oui, mais entre nous c'est qu'il s'agit d'une passerelle-serveur à
destination de qq centaines détablissements scolaires, et que je ne sais
pas à l'avance de quel matériel ils disposeront et que je me vois mal
demander à des utilisateurs non spécialistes de se cogner ça à la main;-((
Merci de ton aide.
Rakotomandimby (R12y) Mihamina (18/04/2005, 11h42)
( Mon, 18 Apr 2005 11:28:42 +0200 ) Vincent GAUVIN :

> Ben oui, mais entre nous c'est qu'il s'agit d'une passerelle-serveur à
> destination de qq centaines détablissements scolaires, et que je ne sais
> pas à l'avance de quel matériel ils disposeront et que je me vois mal
> demander à des utilisateurs non spécialistes de se cogner ça à la main;-((


Dans ce cas, il faut s'assurer que le module est bien présent dans les
modules du kernel. La distribution semble être optimisée par la taille,
il se peut qu'il aient pris la liberté de ne pas compiler tous les
modules. Essaie donc d'abord de charger le module qui va bien à ta
realtek à la main. Si tu y arrive, décharge-le et on pourra chercher
plus loin. Si tu n'y arrive pas, alors le problème est là.
Rakotomandimby (R12y) Mihamina (18/04/2005, 11h48)
( Mon, 18 Apr 2005 11:28:42 +0200 ) Vincent GAUVIN :
[ problèmes avec vector linux, une slackware-based ]
> Ben oui, mais entre nous c'est qu'il s'agit d'une passerelle-serveur


Juste pour savoir, pourquoi n'as tu pas choisi SME? c'est vraimeznt par
curiosité hein, puisqu'on sait que pour cet usage, il y a IPCop, SME, etc
etc...

X-Post + Follow-Up to fcold
Vincent GAUVIN (18/04/2005, 11h56)
Rakotomandimby (R12y) Mihamina a écrit :
> ( Mon, 18 Apr 2005 11:28:42 +0200 ) Vincent GAUVIN :
> Dans ce cas, il faut s'assurer que le module est bien présent dans les
> modules du kernel. La distribution semble être optimisée par la taille,
> il se peut qu'il aient pris la liberté de ne pas compiler tous les
> modules. Essaie donc d'abord de charger le module qui va bien à ta
> realtek à la main. Si tu y arrive, décharge-le et on pourra chercher
> plus loin. Si tu n'y arrive pas, alors le problème est là.

J'avais déjà essayé aussi. A la main no pb il me charge bien le module
de la realtek.
modprobe ne2k-pci
Rakotomandimby (R12y) Mihamina (18/04/2005, 13h44)
( Mon, 18 Apr 2005 11:56:20 +0200 ) Vincent GAUVIN :
> J'avais déjà essayé aussi. A la main no pb il me charge bien le module
> de la realtek.
> modprobe ne2k-pci


Si tu remets la 3com, elle le système est reconfiguré en conséquence?
Le but est de savoir si kudzu sait reconfigurer un système.
Vincent GAUVIN (18/04/2005, 14h10)
Rakotomandimby (R12y) Mihamina a écrit :
> ( Mon, 18 Apr 2005 11:56:20 +0200 ) Vincent GAUVIN :
>>J'avais déjà essayé aussi. A la main no pb il me charge bien le module
>>de la realtek.
>>modprobe ne2k-pci
>> Si tu remets la 3com, elle le système est reconfiguré en conséquence?

> Le but est de savoir si kudzu sait reconfigurer un système.

voui il sait.
Mais je crois que je suis sur une bonne piste:-)
Je vérifie tout ça et je te tiens au courant
merci de ton aide
Discussions similaires
USB matériel détecté ne s'installe pas

mon pc n'a pas détecté la nouvelle mémoire DDR que j'ai installé

FrameWork NET installé mais pas détecté

DD détecté mais innaccessible


Fuseau horaire GMT +2. Il est actuellement 03h27. | Privacy Policy