cerhu > microsoft.* > microsoft.excel

garnote (05/07/2003, 19h14)
Bonsoir,

J'ai une macro qui inverse l'ordre des valeurs d'une plage
de cellules situées sur une seule colonne et qui dépose
la liste inversée dans la colonne à droite de la sélection.

Sub Inverse_Valeurs_Colonne()
Set ici = Selection
n = ici.Rows.Count
For i = 1 To n
ici(i, 2) = ici(n - i + 1, 1)
Next i
End Sub

Existe-t-il une fonction VBA qui peut faire ça et
est-ce possible d'accomplir la même tâche avec
une formule de feuille de calcul ?

Merci,

Serge
worcq (05/07/2003, 20h15)
Bonjour,
Première fois que je fais appel à ce groupe que je consulte toutefois
régulièrement et que j’apprécie.
Quelqu’un peut-il m’aider ?

date indice kms coût/auto train/bus coût total formation transport dpl
domicile
janvier-03 1 12 € 2,40 € 10,00 € 12,40 € -
janvier-03 2 12 € 2,40 € 2,40 € 2,40
février-03 1 € 10,00 ####### € -

C = Indice 1 2 ou 3
D = kms
E = cout kms * une constante située en $A$ 31
F = train/bus euro monétaire 2décimales
G = coût total = coût/auto +train/bus soit e4+f4

si coût/auto vide alors coût total , que se passe-t-il ?
ma formule : =SI(OU(E5<>"";F5<>"");SI(OU(C5=1;C5=2);E5+F5;0);"" )

merci
Willy
Discussions similaires
Inverser l'ordre d'un tableau

Inverser l'ordre de présentation

COMMENT inverser l'ordre des colonnes?

Inverser l'ordre Prénom NOM.


Fuseau horaire GMT +2. Il est actuellement 08h43. | Privacy Policy